Bug 998751 - [origin_runtime_224]Failed to create drupal-quickstart app
[origin_runtime_224]Failed to create drupal-quickstart app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Vojtech Vitek
libra bugs
:
: 999064 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 22:24 EDT by chunchen
Modified: 2016-09-29 22:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:53:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chunchen 2013-08-19 22:24:52 EDT
Description of problem:
When create a drupal-quickstart app, will meet "Shell command" and "Failed to execute action hook 'build'"errors.

Version-Release number of selected component (if applicable):
devenv_3675

How reproducible:
always

Steps to Reproduce:
1. Create a drupal-quickstart app
rhc app create drupal php-5.3 mysql-5.1 cron --from-code=git://github.com/openshift/drupal-quickstart.git

Actual results:
Using cron-1.4 (Cron 1.4) for 'cron'

Application Options
-------------------
  Namespace:   cdm
  Cartridges:  php-5.3, mysql-5.1, cron-1.4
  Source Code: git://github.com/openshift/drupal-quickstart.git
  Gear Size:   default
  Scaling:     no

Creating application 'drupal' ... 
The initial build for the application failed: Shell command '/sbin/runuser -s /bin/sh 417419912002622774575104 -c "exec /usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c0,c505' /bin/sh -c \"gear
postreceive >> /tmp/initial-build.log 2>&1\""' returned an error. rc=255

.Last 10 kB of build output:
Stopping Cron cartridge
Stopping PHP cartridge
Syntax error on line 2 of /var/lib/openshift/417419912002622774575104/php/configuration/etc/conf.d/openshift.conf:
DocumentRoot must be a directory
httpd (no pid file) not running
Stopping MySQL cartridge
Building PHP cartridge
Checking pear: pear.drush.org/drush

Attempting to discover channel "pear.drush.org"...
downloading channel.xml ...
Starting to download channel.xml (804 bytes)
....done: 804 bytes
Auto-discovered channel "pear.drush.org", alias "drush", adding to registry
downloading drush-6.0.0.tgz ...
Starting to download drush-6.0.0.tgz (508,464 bytes)
...done: 508,464 bytes
install ok: channel://pear.drush.org/drush-6.0.0

Run '. ${OPENSHIFT_DATA_DIR}.bash_profile' to load Drush into your SSH shell.

Download and install the latest stable version of Drupal

The directory /var/lib/openshift/417419912002622774575104/app-root/data/downloads does not exist.
Would you like to create it? (y/n): y
Project drupal (7.23) downloaded to                                    [success]
/var/lib/openshift/417419912002622774575104/app-root/data/downloads/drupal-7.23.
Project drupal contains:                                               [success]
 - 3 profiles: standard, minimal, testing
 - 4 themes: bartik, seven, stark, garland
 - 47 modules: drupal_system_listing_compatible_test,
drupal_system_listing_incompatible_test, update, toolbar, filter,
poll, system, translation, contact, profile, shortcut, contextual,
image, statistics, php, file, path, tracker, blog, trigger,
aggregator, simpletest, menu, locale, user, field_ui, color, book,
node, comment, openid, overlay, help, dblog, rdf, taxonomy, forum,
dashboard, syslog, list, number, field_sql_storage, text, options,
field, block, search

mv: cannot stat `~/app-root/data/downloads/drupal-7.23/sites': No such file or directory
An error occurred executing 'gear postreceive' (exit code: 1)
Error message: Failed to execute action hook 'build' for 417419912002622774575104 application drupal

For more details about the problem, try running the command again with the '--trace' option.

Expected results:
Creating drupal-quickstart app should be successful.

Additional info:
Comment 1 Vojtech Vitek 2013-08-20 07:36:00 EDT
Will be fixed once https://github.com/openshift/drupal-quickstart/pull/5 is merged.
Comment 2 Vojtech Vitek 2013-08-20 07:52:26 EDT
@chunchen, can you re-test against this GIT REPO?

rhc app create drupal php-5.3 mysql-5.1 cron --from-code=git://github.com/VojtechVitek/drupal-quickstart.git
Comment 3 Jhon Honce 2013-08-20 16:12:14 EDT
*** Bug 999064 has been marked as a duplicate of this bug. ***
Comment 5 chunchen 2013-08-20 22:12:00 EDT
@Vojtech Vitek, I tested that GIT REPO in #Comment 2 on devenv_3680,the drupal-quickstart can be created successfully.
Comment 6 Vojtech Vitek 2013-08-21 07:39:38 EDT
@chunchen, thanks. I will move ON_QA once it gets merged into master.
Comment 7 Vojtech Vitek 2013-08-22 10:26:29 EDT
https://github.com/openshift/drupal-quickstart/pull/7 merged
Comment 8 chunchen 2013-08-22 22:06:10 EDT
It's fixed, verified on devenv_3690, please refer to the following results:

# rhc app create drupal3 php-5.3 mysql-5.1 cron --from-code=git://github.com/openshift/drupal-quickstart.git
Using cron-1.4 (Cron 1.4) for 'cron'

Application Options
-------------------
  Namespace:   ccy
  Cartridges:  php-5.3, mysql-5.1, cron-1.4
  Source Code: git://github.com/openshift/drupal-quickstart.git
  Gear Size:   default
  Scaling:     no

Creating application 'drupal3' ... done

  To schedule your scripts to run on a periodic basis, add the scripts to 
your application's .openshift/cron/{minutely,hourly,daily,weekly,monthly}/
directories (and commit and redeploy your application).
Example: A script .openshift/cron/hourly/crony added to your application
         will be executed once every hour.
         Similarly, a script .openshift/cron/weekly/chronograph added
         to your application will be executed once every week.
MySQL 5.1 database added.  Please make note of these credentials:
       Root User: adminK8Yr4EZ
   Root Password: nSHh6xIv4I62
   Database Name: drupal3
Connection URL: mysql://$OPENSHIFT_MYSQL_DB_HOST:$OPENSHIFT_MYSQL_DB_PORT/
You can manage your new MySQL database by also embedding phpmyadmin-3.
The phpmyadmin username and password will be the same as the MySQL credentials above.

Waiting for your DNS name to be available ... done

Cloning into 'drupal3'...
The authenticity of host 'drupal3-ccy.dev.rhcloud.com (54.224.237.167)' can't be established.
RSA key fingerprint is fe:1c:20:a4:18:62:29:78:b1:fe:8b:41:4b:23:05:b2.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'drupal3-ccy.dev.rhcloud.com' (RSA) to the list of known hosts.

Your application 'drupal3' is now available.

  URL:        http://drupal3-ccy.dev.rhcloud.com/
  SSH to:     581622424428966051840000@drupal3-ccy.dev.rhcloud.com
  Git remote: ssh://581622424428966051840000@drupal3-ccy.dev.rhcloud.com/~/git/drupal3.git/
  Cloned to:  /root/test/drupal3

Run 'rhc show-app drupal3' for more details about your app.

Note You need to log in before you can comment on or make changes to this bug.