Bug 998755 - Kernel stopped supporting usb-storage on GT-E2652W
Kernel stopped supporting usb-storage on GT-E2652W
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 998754 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 22:44 EDT by Greg Hosler
Modified: 2013-08-21 09:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 09:04:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog demonstrating probe and fail to mount (2.11 KB, text/plain)
2013-08-19 22:46 EDT, Greg Hosler
no flags Details
syslog of probe and mount fail (1.89 KB, text/plain)
2013-08-19 22:47 EDT, Greg Hosler
no flags Details
syslog from earlier kernel demonstrating probe and successful mount (2.69 KB, text/plain)
2013-08-19 22:48 EDT, Greg Hosler
no flags Details

  None (edit)
Description Greg Hosler 2013-08-19 22:44:47 EDT
Description of problem:

usb-storage no longer works on Samsung GT-E2652W phone


Version-Release number of selected component (if applicable):

Starting with kernel 3.10.3-300.fc19.x86_64, and continuing with kernel
3.10.4-300.fc19.x86_64 this no longer works.

Every kernel prior, including earlier Fedora-19 3.9.* kernels and all kernels in Fedora-18 and earlier back to at least Fedora-13 (possibly/probably earlier), worked.

I was able to plug my phone into the usb port, and it would automatically mount.

How reproducible:

100% reproduceable fail in 3.10 kernels.

Steps to Reproduce:
1. Plug phone in.
2. Wait 30 secs. Phone does not mount in 3.10*, does mount in 3.9.*
3.

Actual results:


Expected results:


Additional info: sys
Comment 1 Greg Hosler 2013-08-19 22:46:01 EDT
Created attachment 788260 [details]
syslog demonstrating probe and fail to mount
Comment 2 Greg Hosler 2013-08-19 22:47:33 EDT
Created attachment 788261 [details]
syslog of probe and mount fail
Comment 3 Greg Hosler 2013-08-19 22:48:36 EDT
Created attachment 788262 [details]
syslog from earlier kernel demonstrating probe and successful mount
Comment 4 Greg Hosler 2013-08-19 22:50:31 EDT
if someone can point me to the relevant kernel module(s), I am happy to do further diagnosis. I have the necessary programming background and feel somewhat comfortable poking around kernel code.
Comment 5 Greg Hosler 2013-08-19 22:52:22 EDT
*** Bug 998754 has been marked as a duplicate of this bug. ***
Comment 6 Josh Boyer 2013-08-20 08:35:57 EDT
Please update to the 3.10.7 kernel.  It contains fixes that make USB storage work again.  If that doesn't work, please let us know.
Comment 7 Greg Hosler 2013-08-20 10:43:01 EDT
Would that be:

     kernel-debug

from the fedora (19) updates repo ?

I ask because I do not see kernel 3.10.7-200.fc19, and do not usually have the updates repo enabled.

Many thanks, and all the best,

-Greg Hosler
Comment 8 Josh Boyer 2013-08-20 10:55:50 EDT
https://admin.fedoraproject.org/updates/kernel-3.10.7-200.fc19

Not sure why you don't see that in the repos.  It's been pushed out.
Comment 9 Greg Hosler 2013-08-21 06:32:55 EDT
[ghosler@localhost ~]# uname -r
3.10.7-200.fc19.x86_64.debug

The bug is fixed here. The phone auto mounts as per pre 3.10.3 kernels.

As an aside, the 3.10.7-200 kernel appears to have been built only as a debug kernel. That's why I didn't see it in the repo. I was looking for kernel-3.10* not kernel-debug-3.10*

Bug can be closed as of 3.10.7-200

Many thanks, and all the best.

-Greg
Comment 10 Josh Boyer 2013-08-21 09:04:31 EDT
(In reply to Greg Hosler from comment #9)
> [ghosler@localhost ~]# uname -r
> 3.10.7-200.fc19.x86_64.debug
> 
> The bug is fixed here. The phone auto mounts as per pre 3.10.3 kernels.
> 
> As an aside, the 3.10.7-200 kernel appears to have been built only as a
> debug kernel. That's why I didn't see it in the repo. I was looking for
> kernel-3.10* not kernel-debug-3.10*

No, it isn't only built as a debug kernel.  It's built both debug and non-debug.  It's right there on the build page.  Here's a direct link:

http://kojipkgs.fedoraproject.org//packages/kernel/3.10.7/200.fc19/x86_64/kernel-3.10.7-200.fc19.x86_64.rpm

If whatever repo you're using only had kernel-debug, then that repo is broken.
 
> Bug can be closed as of 3.10.7-200

Thanks.

Note You need to log in before you can comment on or make changes to this bug.