Bug 998789 - Fail to restart a scalable or unscalable php-5.3 app
Fail to restart a scalable or unscalable php-5.3 app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Michal Fojtik
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 01:33 EDT by congqiyuan
Modified: 2015-05-14 19:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:53:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description congqiyuan 2013-08-20 01:33:11 EDT
Description of problem:
Fail to restart a scalable or unscalable php-5.3 app

Version-Release number of selected component (if applicable):
devenv_3676

How reproducible:
always

Steps to Reproduce:
1.create a scaling php-5.3 app
2.restart the app


Actual results:
Unable to complete the requested operation due to: Failed to correctly execute all parallel operations.
Reference ID: a9270187f4ab1e99823e97ce1d1e7f0e


Expected results:
should restart success

Additional info:
development.log 
2013-08-19 23:28:13.362 [ERROR] Failed to correctly execute all parallel operations (pid:2888)
2013-08-19 23:28:13.573 [ERROR] Reference ID: 09ecd4821f8860c154aca16bb8c07e9f - Failed to correctly execute all parallel operations
2013-08-19 23:28:35.488 [ERROR] Failed to correctly execute all parallel operations (pid:2888)
2013-08-19 23:28:35.488 [ERROR] ["/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.13.5/app/models/pending_app_op_group.rb:404:in `execute'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.13.5/app/models/application.rb:1384:in `run_jobs'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.13.5/app/models/application.rb:845:in `block in restart'"
Comment 1 Tian Feng 2013-08-20 01:49:06 EDT
Test on devenv_3676, cannot restart scaling php app via website either. It returns "We appear to be having techincal difficulties" error message.
Comment 2 Michal Fojtik 2013-08-20 07:59:20 EDT
Fix: https://github.com/openshift/origin-server/pull/3424

I'm sorry for this typo :)
Comment 3 openshift-github-bot 2013-08-21 11:00:34 EDT
Commits pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/ae3a3ed6ebfd6bfc212130a68f7851c8b4a7003c
Bug 998789 - Fixed a typo in PHP cartridge control script

https://github.com/openshift/origin-server/commit/3f4dcf3f30ba81e87817aa57e3202bd7b5ab4629
Merge pull request #3424 from mfojtik/bugzilla/998789

Bug 998789 - Fixed a typo in PHP cartridge control script
Comment 4 Tian Feng 2013-08-21 23:27:23 EDT
Test on devenv-stage_448, can restart both scalable and non-scalable php application, and can also restart app with php cartridges. So verified this bug, thanks!

Note You need to log in before you can comment on or make changes to this bug.