Bug 998793 - quota: auxiliary mount should use some arbitrary name
quota: auxiliary mount should use some arbitrary name
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: krishnan parthasarathi
Saurabh
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 01:44 EDT by Saurabh
Modified: 2016-01-19 01:15 EST (History)
12 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.37rhs-1
Doc Type: Bug Fix
Doc Text:
Previously, for a quota enabled volume the auxiliary mount would be mounted at /tmp/<volname>. Now, with this update, the auxiliary mount is mounted at /var/run/gluster/<volname>.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:31:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
agunn: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-08-20 01:44:50 EDT
Description of problem:
volume name used to mount a volume while doing a auxiliary mount.

Version-Release number of selected component (if applicable):
glusterfs-server-3.4.0.20rhsquota1-1.el6.x86_64
glusterfs-fuse-3.4.0.20rhsquota1-1.el6.x86_64
glusterfs-3.4.0.20rhsquota1-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. create a 6x2 volume, start it
2. enable quota
3.

Actual results:
the auxiliary mount created shows that the mount includes 
/tmp/<volume-name>
localhost:dist-rep2   1.1T  266M  1.1T   1% /tmp/dist-rep2

Expected results:
we should get away with this kind of mount point as the name should be some arbitrary name

Additional info:
Comment 11 Saurabh 2013-10-28 02:54:01 EDT
As I know that the quota related mount is done if one issues a quota list command, as per the fix the mount should be in /var/run/gluster.

Actaully this not the case on "glusterfs-3.4.0.36rhs", can be seen in the logs mentioned below.

the mount still can be under /tmp.

[root@nfs2 ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_nfs2-lv_root
                       50G  1.8G   45G   4% /
tmpfs                 4.0G     0  4.0G   0% /dev/shm
/dev/vda1             485M   32M  428M   7% /boot
/dev/mapper/vg_nfs2-lv1
                      425G   19G  407G   5% /rhs/bricks
[root@nfs2 ~]# ls /var/run/gluster
[root@nfs2 ~]# gluster volume quota quota-dist-rep list /1
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/1                                         1.0GB       80%       1.0GB  0Bytes

[root@nfs2 ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_nfs2-lv_root
                       50G  1.8G   45G   4% /
tmpfs                 4.0G     0  4.0G   0% /dev/shm
/dev/vda1             485M   32M  428M   7% /boot
/dev/mapper/vg_nfs2-lv1
                      425G   19G  407G   5% /rhs/bricks
localhost:quota-dist-rep
                      2.5T   98G  2.4T   4% /tmp/quota-dist-rep

[root@nfs2 ~]# glusterfs -V
glusterfs 3.4.0.36rhs built on Oct 22 2013 10:56:17
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2013 Red Hat, Inc. <http://www.redhat.com/>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
It is licensed to you under your choice of the GNU Lesser
General Public License, version 3 or any later version (LGPLv3
or later), or the GNU General Public License, version 2 (GPLv2),
in all cases as published by the Free Software Foundation.

[root@nfs2 ~]# ls /var/run/gluster
quota-dist-rep.pid
[root@nfs2 ~]#
Comment 12 Saurabh 2013-11-04 03:49:33 EST
mount is seen different path, i.e. 
[root@nfs1 ~]# df -h /var/run/gluster/dist-rep12
Filesystem            Size  Used Avail Use% Mounted on
localhost:dist-rep12  2.5T  451G  2.1T  18% /var/run/gluster/dist-rep12


and even after setting the quota-deem-statfs to on,
[root@nfs1 ~]# df -h /var/run/gluster/dist-rep12
Filesystem            Size  Used Avail Use% Mounted on
localhost:dist-rep12  100G  8.0G   93G   8% /var/run/gluster/dist-rep12

verified on glusterfs-3.4.0.38rhs-1
Comment 13 errata-xmlrpc 2013-11-27 10:31:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.