Bug 998822 - Can't register to SAM when auto install RHEVH 6.4-20130815.0.el6_4
Can't register to SAM when auto install RHEVH 6.4-20130815.0.el6_4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: 6.5
Assigned To: Joey Boggs
Virtualization Bugs
: Reopened, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 03:34 EDT by Longjun Song
Modified: 2014-01-21 14:48 EST (History)
20 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-8.el6
Doc Type: Bug Fix
Doc Text:
autoinstallations with activation keys for sam failed to register properly, when using activation keys with a sam registration rather that just user/pass. This was caused because the --auto-attach option was being used. It is no longer used in conjunction with activation keys, so registration is successful.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:48:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attachment the file ovirt.log (209.46 KB, text/x-log)
2013-08-20 03:34 EDT, Longjun Song
no flags Details

  None (edit)
Description Longjun Song 2013-08-20 03:34:36 EDT
Created attachment 788343 [details]
attachment the file ovirt.log

Description of problem:
Can't register to SAM successfully when auto install RHEV Hypervisor 6.4-20130815.el6_4 by adding
kernel parameters: rhn_type=sam rhn_url=xxx rhn_cacert=xxx rhn_org=ACME_Corporation rhn_activationkey=xxx. In /var/log/ovirt.log
there is an error said:

  Registering to RHN account.....
  ['/usr/sbin/subscription-manager', 'register', '--activationkey', 'rhevh', '--org', 'ACME_Corporation', '--force', '--autosubscribe']
  Error: Activation keys cannot be used with --auto-attach.


Version-Release number of selected component (if applicable):
RHEV Hypervisor 6.4-20130815.0.el6_4

How reproducible:
100%

Steps to Reproduce:
1. Auto install a RHEV Hypervisor 6.4-20130815.0.el6_4 by adding kernel parameters like this: BOOTIF=eth0 storage_init=/dev/sda rhn_type=sam  rhn_url=xxx rhn_ca_cert=xxx rhn_org=ACME_Corporation rhn_activationkey=xxxx.


Actual results:
 After reboot, select the Red Hat Network TAB, it will show nothing about the register information.Check the log information in /var/log/ovirt.log and there is an error recorded like above description.

Expected results:


Additional info:
Press F2 to drop in shell and execute following command:/usr/sbin/subscription-manager register --activationkey=rhevh --org=ACME_Corporation --force 
will register to SAM successfully.
Comment 3 haiyang,dong 2013-08-21 06:23:53 EDT
I found the issue happen on package "subscription-manager",

Tried the follow two version:
1.Test version:
RHEV Hypervisor 6.4-20121015.1.el6
subscription-manager-1.1.2-1.el6.x86_64

[root@dhcp-9-80 admin]# /usr/sbin/subscription-manager register --activationkey=rhevh12 --org=ACME_Corporation --force --autosubscribe
The system has been registered with id: 1263d60b-b83b-47a0-a60b-83643f70db8c 
Installed Product Current Status:

For the old package "subscription-manager", it support using "--autosubscribe" when using "activationkey" to register SAM.
Also register to SAM using activationkey success during rhev-h auto install 

2.Test version:
RHEV Hypervisor 6.4-20130815.0.el6_4 
subscription-manager-1.1.23.1-1.el6_4.x86_64

[root@dhcp-9-84 admin]# /usr/sbin/subscription-manager register --activationkey=rhevh --org=ACME_Corporation --force --autosubscribe
Error: Activation keys cannot be used with --auto-attach.

For the new package "subscription-manager", it didn't support using "--autosubscribe" when using "activationkey" to register SAM.

Also register to SAM using activationkey failed during rhev-h auto install.

Taking off --autosubscribe from ovirt-node is a easy solution to fix this bug.
Comment 4 gaoshang 2013-08-22 00:00:27 EDT
This issue also exist on rhel5.10 + SAM 1.3 snap 2(SAM-1.3.0-RHEL-6-20130815.0), it seems like we can not use "--auto-attach" any more when register with --activationkey, could anyone help to confirm it, thanks.
Comment 5 Bryan Kearney 2013-09-09 13:14:16 EDT
they should work together. Snap2 had an issue with auto-attach. Please verify with Snap5. If that still fails, can you re-assign to SAM?
Comment 6 gaoshang 2013-09-09 22:53:17 EDT
(In reply to Bryan Kearney from comment #5)
> they should work together. Snap2 had an issue with auto-attach. Please
> verify with Snap5. If that still fails, can you re-assign to SAM?

Hi Bryan,

I verified this bug against SAM snapshot 5 but still failed, please see the following prompt.

# subscription-manager register --org ACME_Corporation --activationkey test --auto-attach
Error: Activation keys cannot be used with --auto-attach.

And re-assigned this bug to SAM, thanks.
Comment 8 Bryan Kearney 2013-09-10 09:42:56 EDT
I have verified, this is a restriction in subscription manager (thanks tom). I am closing this out. If you feel this should be supported, please open an RFE for subscription manager. The work around is to run auto attach after you register.
Comment 11 Bryan Kearney 2013-09-17 13:39:22 EDT
This is actually not relatd to SAM, rather because of https://bugzilla.redhat.com/show_bug.cgi?id=869729. Do you need the activation key? If so, wecan revert the fix for 6.5.
Comment 19 Cheryn Tan 2014-01-08 00:37:13 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 23 errata-xmlrpc 2014-01-21 14:48:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.