Bug 998847 - Overview display problem in Gnome with 2 different Monitor resolutions
Overview display problem in Gnome with 2 different Monitor resolutions
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 04:14 EDT by Rolle
Modified: 2013-08-20 04:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 04:53:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
monitor resolutions (1.32 KB, text/plain)
2013-08-20 04:14 EDT, Rolle
no flags Details
Background images on the 2 desktops (this is ok) (8.55 MB, image/png)
2013-08-20 04:18 EDT, Rolle
no flags Details
Background images on the 2 desktops (this is not ok) (6.23 MB, image/png)
2013-08-20 04:22 EDT, Rolle
no flags Details

  None (edit)
Description Rolle 2013-08-20 04:14:10 EDT
Created attachment 788365 [details]
monitor resolutions

Description of problem:
I have 2 monitors with different resolutions (see attachment "monitor resolutions". Now then I go to the overview mode (super key) the background image is wrong scaled. (See attachments). It looked like the original background image no scaled and only it darkened, but another copy of the background image is overlayed with a wrong scaling.

Version-Release number of selected component (if applicable):
Fedora 19, Gnome-shell "gnome-shell.x86_64 0:3.8.4-1.fc19"

How reproducible:
everytime

Steps to Reproduce:
1. Connect 2 monitors with different resolutions
2. go to overview mode (super/windows key)
3.

Actual results:
The background image of the bigger monitor resolution is wrong scaled (to the resolution of the smaller monitor resolution size) and overlayed to the original background image.

Expected results:
The background image of both screens should only darkened without scaling.

Additional info:
Maybe there is a dependency of the main monitor screen and the second monitor screen:
My configuration of the 2 monitors are so, that gnome/x.org priorisies my smaller monitor as main monitor (HDMI-3) and the bigger one as second monitor (DVI-0). So I changed the monitor order in gnome settings to the bigger one as my main desktop and the lower one as second desktop. I couldn't change the monitor cables to the graphics card ports, because my big monitor has only a DVI-port.
Maybe this is an unnessecary dependency in gnome to compute window-/background-scalings in overview mode?
Comment 1 Rolle 2013-08-20 04:18:03 EDT
Created attachment 788367 [details]
Background images on the 2 desktops (this is ok)
Comment 2 Rolle 2013-08-20 04:22:17 EDT
Created attachment 788379 [details]
Background images on the 2 desktops (this is not ok)
Comment 3 Rolle 2013-08-20 04:52:51 EDT
Oh. I updated my system now and with the package "gnome-shell.x86_64 0:3.8.4-2.fc19" it is fixed. I close this bug.

Sorry and thank you for the good work

Note You need to log in before you can comment on or make changes to this bug.