Bug 998855 - Hotplug of vnic not working correctly with no guest running
Hotplug of vnic not working correctly with no guest running
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Linux
medium Severity medium
: ---
: 3.3.0
Assigned To: psebek
network
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 04:45 EDT by Artyom
Modified: 2016-02-10 14:55 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 06:40:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
egine and vdsm logs (20.00 KB, application/gzip)
2013-08-20 04:45 EDT, Artyom
no flags Details
Relevant logs (80.00 KB, application/gzip)
2013-09-01 02:19 EDT, Artyom
no flags Details

  None (edit)
Description Artyom 2013-08-20 04:45:11 EDT
Created attachment 788384 [details]
egine and vdsm logs

Description of problem:
After adding vm1 and unplug vnic from running vm1, functions as adding new vnic to vm1, plug vnic stop working with error"
"Error while executing action Edit VM Interface properties: Failed to activate VM Network Interface. "

Version-Release number of selected component (if applicable):
rhevm - is10
vdsm of host - vdsm-4.12.0-61.git8178ec2.el6ev
libvirt on host - libvirt-0.10.2-18.el6_4.9

How reproducible:
Always

Steps to Reproduce:
1. Add clean vm with nic
2. Run vm, wait untill vm is UP and unplug nic
3. After this try to plug nic or add new nic to vm

Actual results:
Error message:
"Error while executing action Edit VM Interface properties: Failed to activate VM Network Interface."

Expected results:
nic plugged in time that vm is running, new nic added in time that vm is running

Additional info:
if I stop vm1 and after this do plug or add new vnic, all work fine.
Comment 1 Dan Kenigsberg 2013-08-27 16:45:54 EDT
Please attach relevant part of libvirtd.log, as we have

Hotplug NIC xml: <inte
rface type="bridge">
        <address  domain="0x0000"  function="0x0"  slot="0x03"  type="pci" bus="0x00"/>
        <mac address="00:1a:4a:98:60:8d"/>
        <model type="virtio"/>
        <source bridge="rhevm"/>
        <filterref filter="vdsm-no-mac-spoofing"/>
        <link state="up"/>
</interface>

....

    if ret == -1: raise libvirtError ('virDomainAttachDevice() failed', dom=self)
libvirtError: An error occurred, but the cause is unknown


Pardon my asking, but is libvirt-0.10.2-18.el6_4.9 our latest and greatest version for RHEL-6.4?
Comment 4 Artyom 2013-09-01 02:19:34 EDT
Created attachment 792525 [details]
Relevant logs

From is12 adding nic after unplugging start work correct but plugging still not work
Comment 5 Dan Kenigsberg 2013-09-02 17:53:52 EDT
Which guest is running in the VM? hotplug/unplug is know to require a responsive modern OS. Without a guest, hotunplug silently fails. Then the following hotplug fails with a lot of bells and whistles.
Comment 6 Artyom 2013-09-03 06:35:10 EDT
It clean installed vm, without any os
Comment 7 Dan Kenigsberg 2013-09-03 06:40:55 EDT
The whole stack (qemu, libvirt, vdsm, Engine) requires a modern guest OS to be operational in order for hotplug/hotunplug to work.

It's not a vdsm bug, hence the CLOSE reason.

Note You need to log in before you can comment on or make changes to this bug.