Bug 998868 - RDP version 4 return "X Error of failed request: BadAtom (invalid Atom parameter)" after closing remote window
RDP version 4 return "X Error of failed request: BadAtom (invalid Atom param...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rdesktop (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Søren Sandmann Pedersen
Desktop QE
:
Depends On:
Blocks: 998873
  Show dependency treegraph
 
Reported: 2013-08-20 05:21 EDT by Vera Budikova
Modified: 2014-06-18 05:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 998873 (view as bug list)
Environment:
Last Closed: 2014-06-02 09:24:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vera Budikova 2013-08-20 05:21:29 EDT
Description of problem:
RDP version 4 return "X Error of failed request: BadAtom (invalid Atom parameter)" after closing remote window.

Version-Release number of selected component (if applicable):
rdesktop-1.8.0-1.fc19.x86_64
rdesktop-1.6.0-8
rdesktop-1.7.1-1.el6

How reproducible:
100% (Windows XP Professional, Windows 7, Windows 2008 Server)

Steps to Reproduce:
1. Type # rdesktop $WindowsIP -4
2. Close the remote window

Actual results:
User can access remote window based on RDP 4, but after closing following message is shown:
X Error of failed request:  BadAtom (invalid Atom parameter)
  Major opcode of failed request:  23 (X_GetSelectionOwner)
  Atom id in failed request:  0x0
  Serial number of failed request:  10217
  Current serial number in output stream:  10217

Expected results:
No warning/error message is shown.

Additional info:
Comment 1 RHEL Product and Program Management 2014-03-07 08:57:25 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:24:12 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.