Bug 998931 - java.io.IOException: Cannot run program "C:\Program": CreateProcess error=2, The system cannot find the file specified
java.io.IOException: Cannot run program "C:\Program": CreateProcess error=2, ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Windows
unspecified Severity unspecified
: ER2
: 6.0.0
Assigned To: Miles Tjandrawidjaja
Pavol Srna
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 07:13 EDT by Pavol Srna
Modified: 2014-09-03 00:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavol Srna 2013-08-20 07:13:12 EDT
Actual results:

* Installer can finish successfully but the exception is thrown.


Expected results:

* Installer finish successfully and no exception is thrown.


Stack trace:

java.io.IOException: Cannot run program "C:\Program": CreateProcess error=2, The system cannot find the file specified
        at java.lang.ProcessBuilder.start(Unknown Source)
        at java.lang.Runtime.exec(Unknown Source)
        at java.lang.Runtime.exec(Unknown Source)
        at java.lang.Runtime.exec(Unknown Source)
        at com.izforge.izpack.util.LibraryRemover.initJavaExec(LibraryRemover.java:144)
        at com.izforge.izpack.util.LibraryRemover.<init>(LibraryRemover.java:111)
        at com.izforge.izpack.util.LibraryRemover.invoke(LibraryRemover.java:129)
        at com.izforge.izpack.util.Librarian.cleanUp(Librarian.java:687)
        at com.izforge.izpack.util.Housekeeper.shutDown(Housekeeper.java:124)
        at com.izforge.izpack.installer.InstallerFrame.exit(InstallerFrame.java:1329)
        at com.izforge.izpack.installer.InstallerFrame$NavigationHandler.navigate(InstallerFrame.java:1800)
        at com.izforge.izpack.installer.InstallerFrame$NavigationHandler.access$100(InstallerFrame.java:1765)
        at com.izforge.izpack.installer.InstallerFrame$NavigationHandler$1.run(InstallerFrame.java:1782)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
        at java.lang.ProcessImpl.create(Native Method)
        at java.lang.ProcessImpl.<init>(Unknown Source)
        at java.lang.ProcessImpl.start(Unknown Source)
        ... 14 more
Comment 2 Miles Tjandrawidjaja 2013-08-20 12:10:39 EDT
Hey Pavol,

Could you please provide the steps to reproduce the bug.

I've tried to emulate this using the jar from:
http://dev138.mw.lab.eng.bos.redhat.com/candidate/soa-6.0.0.ER1/jboss-eap-6.1.0.soa.ci-installer.jar

I was testing on Windows 7 Home Premium 64 bit.
Thank you.

Regards,
Miles Tjandrawidjaja
Comment 3 Pavol Srna 2013-08-20 12:46:11 EDT
* Run `java -jar installer.jar` in console. Wizard will open. 
* Click on the very last button 'Done' in the installer wizard. 
* Check console for exception.

I have used my private win7x86 machine.
Comment 4 Miles Tjandrawidjaja 2013-08-20 16:05:45 EDT
Thanks Pavol.
The issue has been patched.
http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=2a73be0871b291c5d8a60ba3e54e64c68b51a4b9
Comment 5 Pavol Srna 2013-09-17 09:26:04 EDT
Verified in jboss-eap-6.1.0.soa.ci-installer.er2.jar

Note You need to log in before you can comment on or make changes to this bug.