Bug 998982 - rhc setup gives confusing message when used with new account that hasn't accepted the terms on the dashboard
rhc setup gives confusing message when used with new account that hasn't acce...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jessica Forrester
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 09:14 EDT by tcrawley
Modified: 2015-05-14 22:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:53:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tcrawley 2013-08-20 09:14:56 EDT
Description of problem:

When using `rhc setup` for the first time, the following error is displayed if the user hasn't visited the web dashboard to accept the terms:
    Unable to complete the requested operation due to: Found valid credentials but you haven't requested access yet.

Version-Release number of selected component (if applicable):

rhc 1.12.4

How reproducible:

Easy.

Steps to Reproduce:
1. create a new openshift account
2. validate account via emailed link (*don't visit the dashboard*)
3. run `rhc setup`

Actual results:

Unable to complete the requested operation due to: Found valid credentials but you haven't requested access yet.


Expected results:

A better error message. Something like:

Unable to complete requested operation due to: Need to accept terms. Visit <url to dashboard>
Comment 1 Jessica Forrester 2013-08-20 14:38:33 EDT
Fixed in https://github.com/openshift/li/pull/1837

Message changed to:

In order to access and use the OpenShift Online services you will need to accept the terms and conditions.  Visit the OpenShift Online console to accept the terms and conditions

Including the url to the terms/accept page in the error message has been added as a story in the backlog.
Comment 2 openshift-github-bot 2013-08-20 17:40:15 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/c58c968d50d722e068fdd67d9976b1438c8b38d6
Bug 998982 - improve msg exposed in rhc when user hasnt accepted terms
Comment 3 Wei Sun 2013-08-21 06:51:00 EDT
Will verify it on devenv_3681
Comment 4 Wei Sun 2013-08-21 23:13:30 EDT
Verifide on devenv-stage_448,rhc is rhc-1.13.5

Result:
[wsun@dhcp-8-229 ~]$ rhc setup
OpenShift Client Tools (RHC) Setup Wizard

This wizard will help you upload your SSH keys, set your application namespace, and check that other programs like Git are properly
installed.

Using bug998982@redhat.com">wsun+bug998982@redhat.com to login to ec2-107-21-140-169.compute-1.amazonaws.com
Password: ******
Unable to complete the requested operation due to: In order to access and use the OpenShift Online services you will need to accept the
terms and conditions.  Visit the OpenShift Online console to accept the terms and conditions.
Reference ID: ba845f3d3ff4cd029fc5e3c8459142a2

Note You need to log in before you can comment on or make changes to this bug.