Bug 998997 - SPM priority doesn't affect the SPM selection
SPM priority doesn't affect the SPM selection
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Tal Nisan
Gadi Ickowicz
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 09:41 EDT by Aharon Canan
Modified: 2016-02-10 15:06 EST (History)
8 users (show)

See Also:
Fixed In Version: is15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:12:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (1.51 MB, application/x-gzip)
2013-08-20 09:41 EDT, Aharon Canan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19092 None None None Never

  None (edit)
Description Aharon Canan 2013-08-20 09:41:43 EDT
Created attachment 788504 [details]
logs

Description of problem:
I set new SPM priority for 2 hosts and it doesn't affect the SPM selection after maintenance 

Version-Release number of selected component (if applicable):
3.3 is10

How reproducible:
100%

Steps to Reproduce:
1. RHEV setup with 2 hosts (both SPM priority set to medium)
2. Change the SPM priority of the current SPM to low.
3. enter both hosts to maintenance and activate them.

Actual results:
although we set different SPM priority, the same SPM remains although it's priority set to low.

Expected results:
the host with medium SPM priority should become SPM

Additional info:
Comment 1 Tal Nisan 2013-09-10 11:09:58 EDT
Please note that the fix refers to a case where you select multiple hosts and run activate, it will not work if you do it manually where one can be activate a few millisecond before the other and get elected as SPM since there are no active hosts at the exact moment.
In any way there is the "select as SPM" feature to help the user change in the case the selection was not as it should
Comment 2 Gadi Ickowicz 2013-09-22 10:13:39 EDT
Verified on is15. The host with medium priority is properly elected as SPM
Comment 3 Itamar Heim 2014-01-21 17:12:16 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.