Bug 999181 - spice-client obsoleted by spice-server, spice-client should be brought back until virt-viewer improves
spice-client obsoleted by spice-server, spice-client should be brought back u...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: spice (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 17:43 EDT by Chad Feller
Modified: 2013-09-19 17:15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-15 08:16:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chad Feller 2013-08-20 17:43:03 EDT
Description of problem:
spice-client was recently obsoleted by spice-server in Fedora when 0.12.4-1 was pushed out in the 'updates' repo. (0.12.0-1 was the previous version that had been pushed.)  

Looking in the changelog, I see that spice-client was dropped, and virt-viewer should be used:

* Fri Aug 02 2013 Hans de Goede <hdegoede@redhat.com> - 0.12.4-1
- New upstream bug-fix release 0.12.4
- Add patches from upstream git to fix sound-channel-free crash (rhbz#986407)
- Add Obsoletes for dropped spice-client sub-package

* Thu May 23 2013 Christophe Fergeau <cfergeau@redhat.com> 0.12.3-2
- Stop building spicec, it's obsolete and superseded by remote-viewer
  (part of virt-viewer)

I tried the remote-viewer program currently in Fedora 18 (virt-viewer-0.5.4-3.fc18.x86_64), and while it works, its performance is not nearly that of spicec.  Video for instance is laggy, and audio and video is not synchronized.  

Downgrading spice-server and reinstalling spice-client yields much better performance on the client (viewing) machine.  

Consider this a request to bring back spice-client until virt-viewer has equivalent performance.


Additional info:

Viewing machine:
Fedora 18
Linux <redacted> 3.10.7-100.fc18.x86_64 #1 SMP Thu Aug 15 22:21:29 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Video card:
07:00.0 VGA compatible controller: NVIDIA Corporation G71GL [Quadro FX 3500] (rev a1)
xorg-x11-drv-nouveau-1.0.7-1.fc18.x86_64

Client machine:
Windows 7 Enterprise, SP1, 64-bit
QXL driver from the 
virtio-win-1.6.5-6.el6_4.noarch
package on RHEL 6.

Server:
RHEL 6.4
Linux <redacted> 2.6.32-358.14.1.el6.x86_64 #1 SMP Mon Jun 17 15:54:20 EDT 2013 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Hans de Goede 2013-09-15 08:16:38 EDT
Bringing back spicec is not going to happen.
Comment 2 Chad Feller 2013-09-16 13:23:50 EDT
(In reply to Hans de Goede from comment #1)
> Bringing back spicec is not going to happen.

Why?  The performance of remote-viewer is clearly lacking compared to spicec.  

The workaround is what I'm doing now, which is to have

  exclude=spice-client, spice-server 

in my yum.conf, but that is not going to work forever.
Comment 3 Chad Feller 2013-09-16 13:29:30 EDT
To be clear, all I'm saying is that obsoleting spicec seemed to be a bit premature, until the new product is 'ready'.  By prematurely yanking spicec, people are left with an inferior product, or an inconvenient workaround.  I realize that it may be an upstream decision, but we can continue to build it no?
Comment 4 Marc-Andre Lureau 2013-09-16 13:58:37 EDT
(In reply to Chad Feller from comment #3)
> To be clear, all I'm saying is that obsoleting spicec seemed to be a bit
> premature, until the new product is 'ready'.  By prematurely yanking spicec,
> people are left with an inferior product, or an inconvenient workaround.  I
> realize that it may be an upstream decision, but we can continue to build it
> no?

It's not clearly not all about speed... spicec is long unmaintained now, and lacks a lot of features.

(In reply to Chad Feller from comment #2)
> (In reply to Hans de Goede from comment #1)
> > Bringing back spicec is not going to happen.
> 
> Why?  The performance of remote-viewer is clearly lacking compared to
> spicec.  

I have done some performance improvement in spice-gtk git, please try with this version please, and perf record / perf report it here.

Please provide more information about your system and your use case (moving a large window around, playing video in fullscreen etc?). I have done profiling recently and it shows similar or better performance in most cases (on modern hardware though).

The design of spice-gtk allows much lower system cpu time, but it does have an extra copy due to cairo usage, which is marginal, given that in general the display is refreshed at frequency of monitor, on a partial/dirty region.
Comment 5 Christophe Fergeau 2013-09-17 04:12:45 EDT
(In reply to Chad Feller from comment #0)
> I tried the remote-viewer program currently in Fedora 18
> (virt-viewer-0.5.4-3.fc18.x86_64), and while it works, its performance is
> not nearly that of spicec.  Video for instance is laggy, and audio and video
> is not synchronized.  

Is that with all videos? Some of them? Do you have examples of laggy videos and of unsync'ed ones? How powerful is the client machine (the one running remote-viewer), and what kind of network do you have between the client and the host?
Comment 6 Chad Feller 2013-09-19 17:15:08 EDT
In reply to Comment #4 and Comment #5:

This is what Smolt was nice for: "here is a link to the hardware".  Anyway...

The viewing machine is a Sun Ultra 40 M2.  (Slightly older, yes. I have a replacement Dell Precision sitting in a box next to my desk.)

CPU: 2 x Dual-Core AMD Opteron(tm) Processor 2222 SE (so 4 cores total.)
Memory: 8 GB RAM
Disk: 2 x SAS HDDs
Video: 07:00.0 VGA compatible controller: NVIDIA Corporation G71GL [Quadro FX 3500] (rev a1)
Driver: xorg-x11-drv-nouveau-1.0.7-1.fc18.x86_64
Kernel: Linux <redacted> 3.10.11-100.fc18.x86_64 #1 SMP Mon Sep 9 13:06:31 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Gigabit Ethernet between the server and the workstation.

The viewing machine has two 24" monitors running at 1920x1200. I always run remote-viewer or spicec on the second monitor, and I'm generally not moving it around. 

The Windows 7 machine in the remote-viewer or spicec window is running at 1680x1050 resolution, and I'm not running the remote-viewer or spicec window any larger than that.

The videos I'm running on the client (Windows 7) machine are not full screen on the VM, and are generally within the browser.  Examples that I have seen it with are Flash based news stories. I'll see if I can find a couple of example video links.

Note You need to log in before you can comment on or make changes to this bug.