Bug 999226 - RHS post install initialization script
RHS post install initialization script
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: redhat-storage-server (Show other bugs)
2.1
All Linux
high Severity high
: ---
: ---
Assigned To: Veda Shankar
Sachidananda Urs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 19:36 EDT by Scott Haines
Modified: 2016-06-12 19:18 EDT (History)
10 users (show)

See Also:
Fixed In Version: redhat-storage-server-2.1.0.3-1.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 962298
Environment:
Last Closed: 2013-09-23 18:25:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Post install script for brick initialization, rhn register and applying perf profile. (9.52 KB, text/plain)
2013-08-28 02:48 EDT, Veda Shankar
no flags Details

  None (edit)
Comment 1 Scott Haines 2013-08-20 19:37:25 EDT
Per PM, requesting script be updated to support 2.1.0 (Big Bend).
Comment 3 Veda Shankar 2013-08-28 02:48:11 EDT
Created attachment 791266 [details]
Post install script for brick initialization, rhn register and applying perf profile.
Comment 4 Veda Shankar 2013-08-28 02:49:08 EDT
Hi,

I have modified the init script for 2.1.
Changes:
  1. Register with RHS 2.1 and RHEL 6.4.z channels.
  2. Introduced "-r" to skip registration per request.

Output from new code:
 ...
Channel(s): rhel-x86_64-server-sfs-6.4.z successfully added
Channel(s): rhel-x86_64-server-6-rhs-2.1 successfully added
Registered Channels:
        rhel-x86_64-server-6-rhs-2.1
        rhel-x86_64-server-6.4.z
        rhel-x86_64-server-sfs-6.4.z
System registered to the correct Red Hat Channels!
 ...

Regards,
Veda
Comment 5 Bala.FA 2013-08-28 08:22:06 EDT
This fix was reviewed at https://code.engineering.redhat.com/gerrit/#/c/12099/
Comment 6 Sachidananda Urs 2013-08-29 03:03:18 EDT
Verified on: redhat-storage-server-2.1.0.3-1.el6rhs.noarch.rpm

[root@boggs .unsupported]# ./rhs-system-init.sh -h
Usage:  rhs-system-init.sh [-h] [-u virtual|object]

General:
  -u <workload>   virtual - RHS is used for storing virtual machine images.
                  object  - Object Access (HTTP) is the primary method to 
                            access the RHS volume.
                  The workload helps decide what performance tuning profile 
                  to apply and other customizations.  
                  By default, the  general purpose workload is assumed.

  -n              Dry run to show what devices will be used for brick creation.
  -r              Skip RHN Registration.
  -h              Display this help.

[root@boggs .unsupported]# 

Verified registering, works good.
Comment 7 Scott Haines 2013-09-23 18:25:15 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.