Bug 999269 - quota: alert message related to soft limit missing
quota: alert message related to soft limit missing
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: krishnan parthasarathi
Saurabh
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 00:52 EDT by Saurabh
Modified: 2016-01-19 01:15 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.34rhs
Doc Type: Bug Fix
Doc Text:
Previously, alert logs were missing when disk consumption of a directory, on which quota limits were set on a quota enabled volume, had crossed the soft-limit. Now, with this update, alert logs are seen when the disk consumption goes above the soft limit set on the directory.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:32:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-08-21 00:52:48 EDT
Description of problem:
Alert message related to the individual directory, should come in the brick log message once it goes beyond the set quota limit.

This is not seen in the present release.

Version-Release number of selected component (if applicable):
glusterfs-server-3.4.0.20rhsquota1-1.el6.x86_64
glusterfs-fuse-3.4.0.20rhsquota1-1.el6.x86_64
glusterfs-3.4.0.20rhsquota1-1.el6.x86_64


How reproducible:
always

Note:
please let me know if you need more information for this issue.
Comment 2 krishnan parthasarathi 2013-08-21 02:20:51 EDT
Could you provide output of "gluster volume info" and all the logs? It would help if you provide all information available, as early as possible.
Comment 5 Amar Tumballi 2013-08-30 05:56:22 EDT
https://code.engineering.redhat.com/gerrit/#/c/12272
Comment 6 Saurabh 2013-10-24 07:40:00 EDT
tried to test on glusterfs-3.4.0.36rhs

based on the below mentioned, moving it to verified,

having four nodes quota[1-4]


result from quota3,

[root@quota3 ~]# less /var/log/glusterfs/bricks/rhs-brick1-d2r13.log | grep "\sA\s"
[2013-10-23 13:32:20.909510] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 2.0GB used by /
[2013-10-23 14:54:22.113042] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 1.0GB used by /qa1/
[2013-10-24 14:19:06.606983] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 913.0MB used by /qa1//dir1-data/
[2013-10-24 15:56:13.860748] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 819.6MB used by /qa1//dir2-data/
[2013-10-24 15:56:13.861049] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 819.6MB used by /qa1//dir2-data/
[2013-10-24 15:56:14.964099] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir3-data/



[root@quota3 ~]# less /var/log/glusterfs/bricks/rhs-brick1-d4r13.log | grep "\sA\s"
[2013-10-23 13:32:19.713432] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 1.9GB used by /
[2013-10-23 14:54:22.136243] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 1.0GB used by /qa1/
[2013-10-24 14:19:05.103873] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 905.0MB used by /qa1//dir1-data/
[2013-10-24 15:56:08.093991] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.2MB used by /qa1//dir2-data/
[2013-10-24 15:56:14.267505] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.2MB used by /qa1//dir3-data/


[root@quota3 ~]# less /var/log/glusterfs/bricks/rhs-brick1-d6r13.log | grep "\sA\s"
[2013-10-23 13:32:27.089227] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 2.0GB used by /
[2013-10-23 14:54:07.434419] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 1000.1MB used by /qa1/
[2013-10-24 14:19:00.377952] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 883.0MB used by /qa1//dir1-data/
[2013-10-24 15:55:55.558234] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir2-data/
[2013-10-24 15:55:55.558261] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir2-data/
[2013-10-24 15:56:11.558424] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.2MB used by /qa1//dir3-data/


result from quota4,
[root@quota4 ~]# less /var/log/glusterfs/bricks/rhs-brick1-d2r23.log | grep "\sA\s"
[2013-10-23 13:32:21.359354] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 2.0GB used by /
[2013-10-23 14:54:22.563121] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 1.0GB used by /qa1/
[2013-10-24 14:19:06.187779] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 908.0MB used by /qa1//dir1-data/
[2013-10-24 15:56:14.275961] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir2-data/
[2013-10-24 15:56:15.531967] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir3-data/
[root@quota4 ~]# 
[root@quota4 ~]# 
[root@quota4 ~]# less /var/log/glusterfs/bricks/rhs-brick1-d4r23.log | grep "\sA\s"
[2013-10-23 13:32:20.163446] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 1.9GB used by /
[2013-10-23 14:54:22.585959] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 1.0GB used by /qa1/
[2013-10-24 14:19:03.163981] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 894.0MB used by /qa1//dir1-data/
[2013-10-24 15:56:08.412331] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.2MB used by /qa1//dir2-data/
[2013-10-24 15:56:14.668730] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir3-data/
[root@quota4 ~]# 
[root@quota4 ~]# less /var/log/glusterfs/bricks/rhs-brick1-d6r23.log | grep "\sA\s"
[2013-10-23 13:32:27.539053] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 2.0GB used by /
[2013-10-23 14:54:07.891104] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 1000.1MB used by /qa1/
[2013-10-24 14:19:00.827219] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 883.0MB used by /qa1//dir1-data/
[2013-10-24 15:55:55.891867] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir2-data/
[2013-10-24 15:56:12.020822] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.2MB used by /qa1//dir3-data/



result from quota1,
[root@quota1 ~]# less /var/log/glusterfs/bricks/rhs-brick1-d1r13.log | grep "\sA\s"
[2013-10-23 13:33:45.810185] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 2.8GB used by /
[2013-10-23 14:54:22.497444] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 1.0GB used by /qa1/
[2013-10-24 14:19:02.291236] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 890.0MB used by /qa1//dir1-data/
[2013-10-24 15:56:11.662205] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.2MB used by /qa1//dir3-data/
[2013-10-24 15:56:12.129866] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir2-data/
[root@quota1 ~]# 
[root@quota1 ~]# less /var/log/glusterfs/bricks/rhs-brick1-d3r13.log | grep "\sA\s"
[2013-10-23 13:32:22.621128] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 2.0GB used by /
[2013-10-23 14:54:22.516350] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 1.0GB used by /qa1/
[2013-10-24 14:18:59.272156] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 876.0MB used by /qa1//dir1-data/
[2013-10-24 15:55:59.551072] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.2MB used by /qa1//dir3-data/
[2013-10-24 15:56:08.995362] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir2-data/
[root@quota1 ~]# less /var/log/glusterfs/bricks/rhs-brick1-d5r13.log | grep "\sA\s"
[2013-10-23 13:32:49.205724] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 2.0GB used by /
[2013-10-23 14:53:34.565958] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 900.0MB used by /qa1/
[2013-10-24 14:19:04.044353] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 898.0MB used by /qa1//dir1-data/
[2013-10-24 15:56:12.953109] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir2-data/
[2013-10-24 15:56:16.083827] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir3-data/


result from quota2,
[root@quota2 ~]# less /var/log/glusterfs/bricks/rhs-brick1-d1r23.log | grep "\sA\s"
[2013-10-23 13:33:45.964545] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 2.8GB used by /
[2013-10-23 14:54:22.651676] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 1.0GB used by /qa1/
[2013-10-24 14:19:02.444622] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 890.0MB used by /qa1//dir1-data/
[2013-10-24 15:56:11.760846] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.2MB used by /qa1//dir3-data/
[2013-10-24 15:56:12.291572] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir2-data/
[root@quota2 ~]# 
[root@quota2 ~]# less /var/log/glusterfs/bricks/rhs-brick1-d3r23.log | grep "\sA\s"
[2013-10-23 13:32:22.774964] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 2.0GB used by /
[2013-10-23 14:54:22.670008] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 1.0GB used by /qa1/
[2013-10-24 14:18:59.426449] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 876.0MB used by /qa1//dir1-data/
[2013-10-24 15:55:59.524992] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir3-data/
[2013-10-24 15:56:09.155549] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir2-data/
[root@quota2 ~]# 
[root@quota2 ~]# less /var/log/glusterfs/bricks/rhs-brick1-d5r23.log | grep "\sA\s"
[2013-10-23 13:32:49.363387] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 2.0GB used by /
[2013-10-23 14:53:34.719749] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 900.0MB used by /qa1/
[2013-10-24 14:19:04.198016] A [quota.c:3608:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 898.0MB used by /qa1//dir1-data/
[2013-10-24 15:56:13.118419] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir2-data/
[2013-10-24 15:56:16.064516] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir3-data/
[2013-10-24 15:56:16.064694] A [quota.c:3602:quota_log_usage] 0-dist-rep3-quota: Usage crossed soft limit: 819.3MB used by /qa1//dir3-data/
Comment 7 errata-xmlrpc 2013-11-27 10:32:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.