Bug 999293 - PCP mislabels newly created log files
PCP mislabels newly created log files
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: pcp (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nathan Scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1065327
  Show dependency treegraph
 
Reported: 2013-08-21 02:05 EDT by Marko Myllynen
Modified: 2015-10-09 05:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1065327 (view as bug list)
Environment:
Last Closed: 2015-10-09 05:21:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2013-08-21 02:05:53 EDT
Description of problem:
After installing PCP on a new system, enabling all PCP services, and letting them run a while, the newly created log files have been mislabeled:

localhost:~# restorecon -v -R /var
restorecon reset /var/log/pcp/pmlogger/localhost/20130821.00.10.meta context system_u:object_r:cron_log_t:s0->system_u:object_r:var_log_t:s0
restorecon reset /var/log/pcp/pmlogger/localhost/20130821.00.10.index context system_u:object_r:cron_log_t:s0->system_u:object_r:var_log_t:s0
restorecon reset /var/log/pcp/pmlogger/localhost/20130820.index context system_u:object_r:cron_log_t:s0->system_u:object_r:var_log_t:s0
restorecon reset /var/log/pcp/pmlogger/localhost/20130820.0 context system_u:object_r:cron_log_t:s0->system_u:object_r:var_log_t:s0
restorecon reset /var/log/pcp/pmlogger/localhost/20130821.00.10.0 context system_u:object_r:cron_log_t:s0->system_u:object_r:var_log_t:s0
restorecon reset /var/log/pcp/pmlogger/localhost/pmlogger.log.prior context system_u:object_r:cron_log_t:s0->system_u:object_r:var_log_t:s0
restorecon reset /var/log/pcp/pmlogger/localhost/20130820.meta context system_u:object_r:cron_log_t:s0->system_u:object_r:var_log_t:s0
localhost:~# 

Version-Release number of selected component (if applicable):
pcp-3.8.2-1.el6.x86_64
selinux-policy-targeted-3.7.19-195.el6_4.12.noarch
Comment 1 Marko Myllynen 2013-09-10 04:15:23 EDT
Also

restorecon reset /etc/pcp/pmlogger/config.default context system_u:object_r:etc_runtime_t:s0->system_u:object_r:etc_t:s0
Comment 2 Marko Myllynen 2015-10-09 05:21:48 EDT
This seems to be fixed in latest RHEL 6 packages.

Note You need to log in before you can comment on or make changes to this bug.