This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 999335 - WebDAV PROPFIND fails for multi-valued properties
WebDAV PROPFIND fails for multi-valued properties
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0
Assigned To: Horia Chiorean
: QA-Closed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 03:55 EDT by Horia Chiorean
Modified: 2016-02-10 03:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 03:58:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker MODE-2010 Major Closed WebDAV throws exception when working with node that has a multi-valued property 2014-02-12 05:23:24 EST

  None (edit)
Description Horia Chiorean 2013-08-21 03:55:56 EDT
When issuing a WebDAV PROPFIND request for a JCR node which has a multi-valued property defined, the following exception is raised:

9:43:49,236 WARN  [org.modeshape.webdav.methods.DoPropfind] (http-/127.0.0.1:8080-4) Sending internal error!: org.modeshape.webdav.exceptions.WebdavException: This method cannot be called on a property with multiple values
	at org.modeshape.web.jcr.webdav.ModeShapeWebdavServlet.translateError(ModeShapeWebdavServlet.java:152) [modeshape-web-jcr-webdav-3.4.0.Final.jar:3.4.0.Final]
	at org.modeshape.web.jcr.webdav.ModeShapeWebdavStore.translate(ModeShapeWebdavStore.java:862) [modeshape-web-jcr-webdav-3.4.0.Final.jar:3.4.0.Final]
	at org.modeshape.web.jcr.webdav.ModeShapeWebdavStore.getCustomProperties(ModeShapeWebdavStore.java:575) [modeshape-web-jcr-webdav-3.4.0.Final.jar:3.4.0.Final]
	at org.modeshape.webdav.methods.DoPropfind.writeCustomProperties(DoPropfind.java:607) [modeshape-webdav-3.4.0.Final.jar:3.4.0.Final]
	at org.modeshape.webdav.methods.DoPropfind.parseProperties(DoPropfind.java:372) [modeshape-webdav-3.4.0.Final.jar:3.4.0.Final]
	at org.modeshape.webdav.methods.DoPropfind.recursiveParseProperties(DoPropfind.java:208) [modeshape-webdav-3.4.0.Final.jar:3.4.0.Final]
	at org.modeshape.webdav.methods.DoPropfind.recursiveParseProperties(DoPropfind.java:222) [modeshape-webdav-3.4.0.Final.jar:3.4.0.Final]
	at org.modeshape.webdav.methods.DoPropfind.execute(DoPropfind.java:157) [modeshape-webdav-3.4.0.Final.jar:3.4.0.Final]
	at org.modeshape.webdav.WebDavServletBean.service(WebDavServletBean.java:141) [modeshape-webdav-3.4.0.Final.jar:3.4.0.Final]
	at org.modeshape.web.jcr.webdav.ModeShapeWebdavServlet.service(ModeShapeWebdavServlet.java:129) [modeshape-web-jcr-webdav-3.4.0.Final.jar:3.4.0.Final]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:847) [jboss-servlet-api_3.0_spec-1.0.2.Final-redhat-1.jar:1.0.2.Final-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:295) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:481) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169) [jboss-as-web-7.2.0.Final-redhat-4.jar:7.2.0.Final-redhat-4]
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
	at java.lang.Thread.run(Thread.java:680) [classes.jar:1.6.0_51]
Caused by: javax.jcr.ValueFormatException: This method cannot be called on a property with multiple values
	at org.modeshape.jcr.JcrMultiValueProperty.getString(JcrMultiValueProperty.java:114) [modeshape-jcr-3.4.0.Final.jar:3.4.0.Final]
	at org.modeshape.web.jcr.webdav.ModeShapeWebdavStore.getCustomProperties(ModeShapeWebdavStore.java:571) [modeshape-web-jcr-webdav-3.4.0.Final.jar:3.4.0.Final]
	... 22 more
Comment 1 JBoss JIRA Server 2013-08-21 10:13:58 EDT
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-2010

Fixed the handling of multi-valued properties in WebDAV: since there doesn't seem to be a standard on how they should be returned to the client, they are ignored and a warning is logged.
Comment 2 JBoss JIRA Server 2013-08-22 12:07:09 EDT
Randall Hauch <rhauch@jboss.org> made a comment on jira MODE-2010

Merged into the 'master' branch.
Comment 4 Horia Chiorean 2013-08-23 03:56:36 EDT
Cherry-picked into product branch: https://github.com/jboss-integration/modeshape/commit/7976db94e597f17789ca372e6b79c16bd285ea36
Comment 9 belong 2013-11-19 18:15:40 EST
Fixed before GA - setting to requires_doc_text- accordingly
Comment 10 Filip Nguyen 2014-02-12 05:23:12 EST
Verified, the exception is no longer thrown, only the following warning is logged:

11:14:39,265 INFO  [MultiPlatformProcessRunner] 11:14:39,265 WARN  [org.modeshape.web.jcr.webdav.ModeShapeWebdavStore] (http-localhost/127.0.0.1:8080-3) The property '/testMultivalued/testProp' will not be returned because it has multiple values

Note You need to log in before you can comment on or make changes to this bug.