Bug 999410 - [RFE] Account provider - make users home's directory removal as optional choice
[RFE] Account provider - make users home's directory removal as optional choice
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openlmi-providers (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Tomáš Bžatek
Robin Hack
: FutureFeature
: 999386 (view as bug list)
Depends On:
Blocks: 922084
  Show dependency treegraph
 
Reported: 2013-08-21 05:40 EDT by Robin Hack
Modified: 2015-03-03 18:06 EST (History)
4 users (show)

See Also:
Fixed In Version: openlmi-providers-0.3.0-1.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:55:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Roman Rakus 2013-08-21 08:05:46 EDT
Only possible way to do it is to add property with this flag.
Comment 3 Roman Rakus 2013-08-22 07:05:08 EDT
What about something like this:
1) check who is owner of user's home dir
2) Is it user to be deleted?
2a - yes) delete home dir
2b - no) Don't touch home dir.

Does it make sense?
Comment 4 Roman Rakus 2013-08-28 09:12:33 EDT
Another option:
Create method named delete_user with parameters.
Comment 5 Roman Rakus 2013-08-28 09:24:52 EDT
Will do the following:
Change behaviour of DeleteInstance to do the check, mark this intrinsic method as deprecated and create extrinsic method with parameters.
Comment 6 Roman Rakus 2013-09-04 07:59:15 EDT
Fixed upstream.
Comment 7 Roman Rakus 2013-09-04 08:06:17 EDT
*** Bug 999386 has been marked as a duplicate of this bug. ***
Comment 11 Ludek Smid 2014-06-13 05:55:19 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.