Bug 999426 - PG-Error while creating gpg-key
PG-Error while creating gpg-key
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
high Severity medium (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Corey Welton
: Regression, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 06:10 EDT by Sachin Ghai
Modified: 2014-04-24 13:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:07:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PG-error while creating a new gpg-key (97.34 KB, image/png)
2013-08-21 06:10 EDT, Sachin Ghai
no flags Details
PG error while selecting "Products & Repositories' tab (125.78 KB, image/png)
2013-09-16 05:29 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2013-08-21 06:10:04 EDT
Created attachment 788783 [details]
PG-error while creating a new gpg-key

Description of problem:
Creating a gpg-key via webUI throws following error:

--
   PGError: ERROR: missing FROM-clause entry for table "products" LINE 1: ...vironment_id" = 1 ORDER BY repositories.name ASC, products.n... ^ : SELECT "repositories".* FROM "repositories" WHERE "repositories"."gpg_key_id" = 2 AND "repositories"."environment_id" = 1 ORDER BY repositories.name ASC, products.name ASC (ActiveRecord::StatementInvalid)
    Click here for more details.
--
Version-Release number of selected component (if applicable):
katello-1.4.3-1.git.256.b710f10.el6.noarch


How reproducible:
always

Steps to Reproduce:
1.Go to Contents--> repository-> gpg  key --> new gpg-key
2. enter name and browse file to upload
3.

Actual results:
PGError: ERROR: missing FROM-clause entry for table "products" LINE 1: ...vironment_id" = 1 ORDER BY repositories.name ASC, products.n... ^ : SELECT "repositories".* FROM "repositories" WHERE "repositories"."gpg_key_id" = 2 AND "repositories"."environment_id" = 1 ORDER BY repositories.name ASC, products.name ASC (ActiveRecord::StatementInvalid)

Expected results:
User should be able to add gpg-key without any error

Additional info:
Comment 2 Justin Sherrill 2013-09-13 17:14:27 EDT
I am unable to reproduce this.  Are you still able to?
Comment 3 Sachin Ghai 2013-09-16 05:01:50 EDT
Not able to reproduce it with following build:

katello-1.4.6-1.git.95.3ef5eb8.el6.noarch
Comment 4 Sachin Ghai 2013-09-16 05:28:09 EDT
Please ignore comment3.

Its reproducible but with different steps:

1.Go to Contents--> repository-> gpg  key --> new gpg-key
2. enter name and browse file to upload
3. select 'Product & Repositories' tab.

The reported error is reproducible now when you select 'Product & Repositories' tab.

Reproducible with: katello-1.4.6-1.git.95.3ef5eb8.el6.noarch
Comment 5 Sachin Ghai 2013-09-16 05:29:31 EDT
Created attachment 798185 [details]
PG error while selecting "Products & Repositories' tab
Comment 6 Justin Sherrill 2013-09-16 10:05:50 EDT
Thanks for looking into this Sachin!

https://github.com/Katello/katello/pull/2957
Comment 9 Corey Welton 2013-09-27 16:04:55 EDT
QE Verified, no more PG error
katello 1.4.6-13.el6sat
Comment 10 Bryan Kearney 2014-04-24 13:07:39 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.