Bug 999432 - Broken deps in Fedora 20
Broken deps in Fedora 20
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdal (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Devrim GÜNDÜZ
Fedora Extras Quality Assurance
:
Depends On: 973829
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 06:18 EDT by Miroslav Suchý
Modified: 2013-08-26 22:25 EDT (History)
10 users (show)

See Also:
Fixed In Version: gdal-1.10.0-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 22:25:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2013-08-21 06:18:23 EDT
Description of problem:
There is broken deps in Fedora 20
Error: Package: gdal-libs-1.9.2-11.fc20.x86_64 (fedora)
           Requires: libpoppler.so.37()(64bit)

Version-Release number of selected component (if applicable):
gdal-libs-1.9.2-11.fc20.x86_64

How reproducible:
always

Steps to Reproduce:
1. yum --releasever=rawhide --disablerepo=rpmfusion* distro-sync


Actual results:
Error: Package: gdal-libs-1.9.2-11.fc20.x86_64 (fedora)
           Requires: libpoppler.so.37()(64bit)


Expected results:
no errors

Additional info:
In Fedora 20 is libpoppler.so.43
Comment 1 Orion Poplawski 2013-08-21 15:33:27 EDT
Looks like 1.10.0 has support for poppler 0.23.  Looks like it is time to update.
Comment 2 Orion Poplawski 2013-08-23 14:52:49 EDT
I'm not entirely sure what we want to do for F20.  Unfortunately there is an abi change from 1.9.2: 

http://upstream-tracker.org/compat_reports/gdal/1.9.2_to_1.10.0/abi_compat_report.html

but no soname bump.  It probably still makes sense to update to 1.10.0 there and rebuild everything rather than trying to back-port the poppler support changes.

# repoquery --whatrequires 'libgdal.so.1()(64bit)' --source | sort -u
GMT-4.5.9-5.fc20.src.rpm
dans-gdal-scripts-0.23-1.fc20.src.rpm
gdal-1.9.2-11.fc20.src.rpm
grass-6.4.2-10.fc20.src.rpm
gtatool-1.5.2-4.fc20.src.rpm
mapnik-2.2.0-4.fc20.src.rpm
mapserver-6.2.1-3.fc20.src.rpm
merkaartor-0.18.1-3.fc19.src.rpm
ncl-6.1.2-3.fc20.src.rpm
nodejs-srs-0.3.1-1.fc20.src.rpm
pfstools-1.8.5-9.fc20.src.rpm
postgis-2.0.3-3.fc20.src.rpm
qgis-1.8.0-14.fc20.src.rpm
qlandkartegt-1.7.3-1.fc20.src.rpm
saga-2.0.8-12.fc20.src.rpm
vfrnav-20130801-1.fc20.src.rpm
xastir-2.0.4-4.fc20.src.rpm
Comment 3 Mat Booth 2013-08-26 16:50:44 EDT
I'm in favour of updating F20 to 1.10.0 and rebuilding all those deps -- there's not many packages in that list and it's probably better (and easier) to do it now before the Alpha release and Bodhi gets enabled.

I can help with rebuilding those packages if you wish (I am a proven packager) just announce it first on the devel mailing list if you want to do this :-)
Comment 4 Orion Poplawski 2013-08-26 22:25:58 EDT
Okay, I'm building 1.10.0 for F20.  Will do some rebuilds tomorrow.

Note You need to log in before you can comment on or make changes to this bug.