Bug 999434 - ugly font rendering
ugly font rendering
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
: 1001734 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 06:23 EDT by Maarten
Modified: 2013-09-03 00:51 EDT (History)
8 users (show)

See Also:
Fixed In Version: 4.1.1.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 00:51:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fc-list -v (460.04 KB, text/plain)
2013-08-22 07:03 EDT, Maarten
no flags Details

  None (edit)
Description Maarten 2013-08-21 06:23:01 EDT
Description of problem:

Wrong font rendering (some random letters becoming bold, strange spacing, overlapping letters). 

Version-Release number of selected component (if applicable):

4.1.0.4-6.fc19

How reproducible:

Always

Steps to Reproduce:
1. Open libreoffice, open a document (.doc)
2. Wait a few minutes
3. Strange font rendering starts (within the document and in LO's GUi)

Actual results:

Wrong font rendering (some random letters becoming bold, strange spacing, overlapping letters). 

Expected results:

Clean text. 

Additional info:

Upon closing the document and opening it again, the fonts are clean again. Also, saving and opening elsewhere shows clean text. So, no corruption enters into the documents, just how the document is shown. 

I tried changing which jre LO is using (e.g. from Oracle's 1.7.0_25 to 1.7.0_05 or free software foundation 1.5.0) or even not using jre, but the problem still appears. 

New to me for LO 4.1 (did not happen in 4.0 or before)
Comment 1 Caolan McNamara 2013-08-22 06:00:26 EDT
Seeing as this doesn't happen for me, and there is just this one isolated report there must be something specific to your setup which triggers this.

What's the output (as an attachment) of
fc-list -v
Comment 2 Maarten 2013-08-22 07:03:00 EDT
Created attachment 789150 [details]
fc-list -v
Comment 3 Felix Homann 2013-08-27 11:49:51 EDT
*** Bug 1001734 has been marked as a duplicate of this bug. ***
Comment 4 Felix Homann 2013-08-27 11:51:38 EDT
Please, take a look at the attachments in
https://bugzilla.redhat.com/show_bug.cgi?id=1001734
Comment 5 Caolan McNamara 2013-08-27 15:08:34 EDT
Odd, v. odd. Are both reporters using KDE ? If so does it make any difference to swap to GNOME for a while, i.e. can it be isolated as triggered by our kde vs gnome front ends.
Comment 6 Felix Homann 2013-08-27 15:54:34 EDT
Swap to Gnome? Arrgh. That's a lot you're demanding ;-)

I'm already at it. I'll let LibreOffice run in Gnome till tomorrow morning and will report.
Comment 7 Felix Homann 2013-08-27 16:52:39 EDT
It's exactly the same in Gnome! Took about an hour for the bug to show up.
Comment 8 Maarten 2013-08-28 05:29:56 EDT
Just to confirm that this happens on KDE. Would you want me to try in gnome as well or is this covered now by comment 7? PS Felix, you won't need to close LibreOffice, just close and re-open the document to get a clean view again.
Comment 9 Felix Homann 2013-08-28 05:49:56 EDT
@Maarten: Reopening a file has not helped here. At least not if there were other crippled documents still open. Maybe it's enough to close *all* open documents.
Comment 10 Maarten 2013-08-28 06:12:32 EDT
Just yum update-d Libreoffice to 4.1.1.2-2.fc19, so far so good without signs of the bug appearing. Will keep on checking.
Comment 11 Felix Homann 2013-08-28 09:29:34 EDT
LibreOffice 4.1.1.2-2.fc19 has been running now for a couple of hours without a problem. We should leave the bug open though for a week or so.
Comment 12 Caolan McNamara 2013-08-28 09:35:02 EDT
That's encouraging anyway. I wonder if this was fdo#67086 otherwise I have no idea which commit might have fixed it.
Comment 13 Maarten 2013-09-03 00:51:06 EDT
I suggest to close this bug now since it appears to have been fixed. Many thanks!

Note You need to log in before you can comment on or make changes to this bug.