Bug 999443 - Virtual Provides on 'cim-server' problematic with DNF
Virtual Provides on 'cim-server' problematic with DNF
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openlmi-providers (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Novacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 06:33 EDT by Jan Synacek
Modified: 2016-11-30 19:31 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 07:12:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Synacek 2013-08-21 06:33:21 EDT
Description of problem:
Both tog-pegasus and sblim-sfcb provide a virtual Provide: cim-server that the openlmi-providers package depends on. If I want to remove for example openlmi-software and no other package depends on tog-pegasus, the tog-pegasus gets removed together with the openlmi-software.


Version-Release number of selected component (if applicable):
dnf-0.3.11-1.git7d717c7.fc20.noarch
openlmi-providers-0.1.1-2.fc20.x86_64


Steps to Reproduce:
1. Install openlmi-software
2. Install tog-pegasus and sblim-sfcb
3. dnf remove openlmi-software
4. Observe


Actual results:
tog-pegasus is removed together with openlmi-software


Expected results:
only openlmi-software is removed


Additional info:
According to Ales Kozumplik, the DNF's author, this *is not* a bug, but a feature that will be on by default. That means that openlmi-providers should probably have its spec file reworked.
Comment 1 Jan Synacek 2013-08-21 07:12:21 EDT
(In reply to Jan Synacek from comment #0)
> Steps to Reproduce:
> 1. Install openlmi-software
> 2. Install tog-pegasus and sblim-sfcb
> 3. dnf remove openlmi-software
> 4. Observe

This is not correct. Step 2 should not be there. I somehow installed openlmi-software and tog-pegasus together (probably when there was no cim server installed, dnf install openlmi-software did that). Meanwhile I also installed sfcb. Step 3 removed tog-pegasus along with openlmi-software, because tog-pegasus was no longer needed by anything.

Note You need to log in before you can comment on or make changes to this bug.