Bug 999507 - openstack-status does not report the status of the neutron services
openstack-status does not report the status of the neutron services
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-utils (Show other bugs)
unspecified
Unspecified Linux
medium Severity medium
: ---
: Havana
Assigned To: lpeer
Ami Jeain
:
: 1007685 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 08:44 EDT by lpeer
Modified: 2016-04-27 01:23 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-utils-2013.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 11:50:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lpeer 2013-08-21 08:44:50 EDT
Description of problem:

After installation of RDO allinone configuration, the execution of openstack-status does not report the status of the Neutron Services
 
This bug is related to the quantum-> neutron renaming.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 lpeer 2013-08-27 06:45:32 EDT
pull request link -

https://github.com/redhat-openstack/openstack-utils/pull/7
Comment 2 Mohammed Arafa 2013-09-14 23:04:15 EDT
hi
i just did a fresh install of havana and only see this:
openstack-nova-network:       dead (disabled on boot)
openstack-nova-scheduler:     active
openstack-nova-volume:        dead (disabled on boot)

nothing about quantum even
Comment 3 Pádraig Brady 2013-09-18 09:06:42 EDT
*** Bug 1007685 has been marked as a duplicate of this bug. ***
Comment 4 Pádraig Brady 2013-09-18 09:09:41 EDT
Version openstack-utils-2013.2-1 is now built and bubbling through fedora/epel/RDO update channels
Comment 5 Mohammed Arafa 2013-09-18 22:43:23 EDT
just updated to openstack-utils-2013.2-1.el6.1.noarch and ran openstack-status

it reports

== neutron services ==
neutron-server:               active
neutron-dhcp-agent:           active
neutron-l3-agent:             active
neutron-metadata-agent:       active
neutron-openvswitch-agent:    active

but doesnt report the networks that neutron is providing.
Comment 6 Pádraig Brady 2013-09-19 04:48:02 EDT
OK thanks for verifying.
Reporting networks is a separate functionality.
How would that logic go?

after_keystone_rc_is_sourced
if any_neutron_service_is_installed
  neutron net-list
Comment 7 Mohammed Arafa 2013-09-26 16:33:37 EDT
if the deployment is a large one, i would guess neutron net-list would be a longish list.

Note You need to log in before you can comment on or make changes to this bug.