Bug 999511 - Unit Test Failures in pulp_rpm/plugins/test/unit/model_factory.py on RHEL5
Unit Test Failures in pulp_rpm/plugins/test/unit/model_factory.py on RHEL5
Status: CLOSED DUPLICATE of bug 999516
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.2
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jay Dobies
Preethi Thomas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 08:55 EDT by Barnaby Court
Modified: 2013-09-09 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 10:17:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barnaby Court 2013-08-21 08:55:50 EDT
Description of problem:  Syntax errors are being thrown by the unit tests in pulp_rpm when the test suite is run on RHEL5.  Specifically syntax errors are being thrown in: pulp_rpm/plugins/test/unit/model_factory.py


Version-Release number of selected component (if applicable): 2.2 & Master


How reproducible:  Easily 


Steps to Reproduce:
1. Run the test suite on RHEL5
2. Inspect the log file for test failures

Actual results:
Unit tests fail on RHEL 5

Expected results:  All unit tests should pass on RHEL 5


Additional info:  

This one failure is causing errors in multiple unit tests

======================================================================
ERROR: Failure: ImportError (No module named functools)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/nose/loader.py", line 381, in loadTestsFromName
    module = self.importer.importFromPath(
  File "/usr/lib/python2.4/site-packages/nose/importer.py", line 39, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/usr/lib/python2.4/site-packages/nose/importer.py", line 86, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/home/jenkins/workspace/pulp_all-rhel5/pulp_rpm/plugins/test/unit/test_associate.py", line 22, in ?
    import model_factory
  File "/home/jenkins/workspace/pulp_all-rhel5/pulp_rpm/plugins/test/unit/model_factory.py", line 14, in ?
    import functools
ImportError: No module named functools
Comment 1 Barnaby Court 2013-08-21 10:17:00 EDT

*** This bug has been marked as a duplicate of bug 999516 ***

Note You need to log in before you can comment on or make changes to this bug.