Bug 999513 - Unit test failures in pulp_rpm/plugins/test/unit/test_config.py on RHEL5
Unit test failures in pulp_rpm/plugins/test/unit/test_config.py on RHEL5
Status: CLOSED DUPLICATE of bug 999516
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
2.2
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Randy Barlow
Preethi Thomas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 09:06 EDT by Barnaby Court
Modified: 2013-08-21 10:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 10:16:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barnaby Court 2013-08-21 09:06:08 EDT
Description of problem: Multiple test cases in pulp_rpm/plugins/test/unit/test_config.py are importing code that is not valid on RHEL5.  


Version-Release number of selected component (if applicable):


How reproducible:  easily


Steps to Reproduce:
1. Run the unit tests for pulp_rpm on RHEL 5
2. observe the log file

Actual results:
======================================================================
ERROR: test_invalid (test_config.ValidateTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jenkins/workspace/pulp_all-rhel5/pulp_rpm/plugins/test/unit/test_config.py", line 43, in test_invalid
    result, error = config_validate.validate(config)
  File "/home/jenkins/workspace/pulp_all-rhel5/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/config_validate.py", line 31, in validate
    importer_config.validate_config(config)
  File "/home/jenkins/workspace/pulp_all-rhel5/pulp/platform/src/pulp/plugins/util/importer_config.py", line 54, in validate_config
    potential_exception = InvalidConfig()
  File "/home/jenkins/workspace/pulp_all-rhel5/pulp/platform/src/pulp/plugins/util/importer_config.py", line 31, in __init__
    super(InvalidConfig, self).__init__()
TypeError: super() argument 1 must be type, not classobj

======================================================================
ERROR: test_valid (test_config.ValidateTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jenkins/workspace/pulp_all-rhel5/pulp_rpm/plugins/test/unit/test_config.py", line 32, in test_valid
    result, error = config_validate.validate(config)
  File "/home/jenkins/workspace/pulp_all-rhel5/pulp_rpm/plugins/pulp_rpm/plugins/importers/yum/config_validate.py", line 31, in validate
    importer_config.validate_config(config)
  File "/home/jenkins/workspace/pulp_all-rhel5/pulp/platform/src/pulp/plugins/util/importer_config.py", line 54, in validate_config
    potential_exception = InvalidConfig()
  File "/home/jenkins/workspace/pulp_all-rhel5/pulp/platform/src/pulp/plugins/util/importer_config.py", line 31, in __init__
    super(InvalidConfig, self).__init__()
TypeError: super() argument 1 must be type, not classobj


Expected results:
Unit tests should run successfully RHEL 5 and a build on RHEL 5 should complete successfully.  If a unit test should not be run on RHEL 5 it should be separated out in the run-tests.py so that it will not run on RHEL 5

Additional info:
Comment 1 Barnaby Court 2013-08-21 10:16:06 EDT

*** This bug has been marked as a duplicate of bug 999516 ***

Note You need to log in before you can comment on or make changes to this bug.