Bug 999527 - AddVmTemplateCommand sends a query that violates not-null constraint
AddVmTemplateCommand sends a query that violates not-null constraint
Status: CLOSED DUPLICATE of bug 999951
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
urgent Severity unspecified
: ---
: 3.3.0
Assigned To: Martin Betak
Tareq Alayan
virt
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 09:34 EDT by Ohad Basan
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-23 11:05:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ohad Basan 2013-08-21 09:34:41 EDT
Description of problem:

2013-08-21 16:05:54,176 ERROR [org.ovirt.engine.core.bll.AddVmTemplateCommand] (ajp-/127.0.0.1:8702-6) Command org.ovirt.engine.core.bll.AddVmTemplateCommand throw exception: org.springframework.dao.DataIntegrityViolationException: CallableStatementCallback; SQL [{call insertvmdevice(?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)}]; ERROR: null value in column "device_id" violates not-null constraint
  Where: SQL statement "INSERT INTO vm_device( device_id, vm_id , device , type, address , boot_order , spec_params, is_managed, is_plugged, is_readonly, alias, custom_properties) VALUES(  $1  ,  $2  ,  $3  ,  $4  ,  $5  ,  $6  ,  $7 ,  $8 ,  $9 ,  $10 ,  $11 ,  $12 )"
PL/pgSQL function "insertvmdevice" line 2 at SQL statement; nested exception is org.postgresql.util.PSQLException: ERROR: null value in column "device_id" violates not-null constraint
  Where: SQL statement "INSERT INTO vm_device( device_id, vm_id , device , type, address , boot_order , spec_params, is_managed, is_plugged, is_readonly, alias, custom_properties) VALUES(  $1  ,  $2  ,  $3  ,  $4  ,  $5  ,  $6  ,  $7 ,  $8 ,  $9 ,  $10 ,  $11 ,  $12 )"
PL/pgSQL function "insertvmdevice" line 2 at SQL statement
Comment 2 Haim 2013-08-23 11:05:30 EDT

*** This bug has been marked as a duplicate of bug 999951 ***

Note You need to log in before you can comment on or make changes to this bug.