Bug 999546 - ModeShape XML sequencer fails when document overwrites default root namespace
ModeShape XML sequencer fails when document overwrites default root namespace
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0
Assigned To: Horia Chiorean
: QA-Closed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 10:18 EDT by Horia Chiorean
Modified: 2016-02-10 03:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 03:56:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker MODE-2011 Major Closed Error Occurred When Publishing File But Client Was Not Notified 2014-02-13 05:54:03 EST

  None (edit)
Description Horia Chiorean 2013-08-21 10:18:22 EDT
When sequencing a document which has a default root namespace (e.g. a pom.xml), the following exception is raised:

8:49:00,442 ERROR [org.modeshape.jcr.SequencingRunner] (modeshape-sequencer-8-thread-3) The 'xml-sequencer' sequencer of repository 'artifacts' had an error while processing '/files/Test/pom.xml/jcr:content/jcr:data' in workspace 'default' and generating output '/derived/xml/Test': javax.jcr.NamespaceException: There is no namespace with URI "http://maven.apache.org/POM/4.0.0"
	at org.modeshape.sequencer.xml.XmlSequencerHandler.startElement(XmlSequencerHandler.java:491)
	at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)
	at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)
	at org.apache.xerces.impl.XMLNSDocumentScannerImpl$NSContentDispatcher.scanRootElementHook(Unknown Source)
	at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
	at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
	at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
	at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
	at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
	at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
	at __redirected.__XMLReaderFactory.parse(__XMLReaderFactory.java:183) [jboss-modules.jar:1.2.0.CR1-redhat-1]
	at org.modeshape.sequencer.xml.XmlSequencer.execute(XmlSequencer.java:133)
	at org.modeshape.jcr.SequencingRunner.run(SequencingRunner.java:224) [modeshape-jcr-3.4.0.Final.jar:3.4.0.Final]
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [classes.jar:1.6.0_51]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [classes.jar:1.6.0_51]
	at java.lang.Thread.run(Thread.java:680) [classes.jar:1.6.0_51]
Caused by: javax.jcr.NamespaceException: There is no namespace with URI "http://maven.apache.org/POM/4.0.0"
	at org.modeshape.jcr.JcrNamespaceRegistry.getPrefix(JcrNamespaceRegistry.java:152) [modeshape-jcr-3.4.0.Final.jar:3.4.0.Final]
	at org.modeshape.jcr.JcrSession.getNamespacePrefix(JcrSession.java:1546) [modeshape-jcr-3.4.0.Final.jar:3.4.0.Final]
	at org.modeshape.sequencer.xml.XmlSequencerHandler.createAttributeName(XmlSequencerHandler.java:500)
	at org.modeshape.sequencer.xml.XmlSequencerHandler.startElement(XmlSequencerHandler.java:463)
Comment 1 JBoss JIRA Server 2013-08-22 09:21:20 EDT
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-2011

Fixed XmlSequencer's handling of default namespaces.
Comment 2 JBoss JIRA Server 2013-08-22 12:34:32 EDT
Randall Hauch <rhauch@jboss.org> made a comment on jira MODE-2011

Rebased and merged into the 'master' branch.
Comment 6 Horia Chiorean 2013-08-23 04:22:17 EDT
Cherry picked into product branch: https://github.com/jboss-integration/modeshape/commit/fe603bc8e9924cc9c705b6d49eeef1afb9895c7c
Comment 10 JBoss JIRA Server 2013-10-24 05:18:18 EDT
Randall Hauch <rhauch@jboss.org> updated the status of jira MODE-2011 to Closed
Comment 11 belong 2013-11-19 18:15:53 EST
Fixed before GA - setting to requires_doc_text- accordingly

Note You need to log in before you can comment on or make changes to this bug.