This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 999571 - 2nd network card no longer accessible/usable
2nd network card no longer accessible/usable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 999572 999573 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 11:11 EDT by wwaustin
Modified: 2014-04-30 08:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-30 08:51:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wwaustin 2013-08-21 11:11:51 EDT
Description of problem:

This machine has 2 network cards.  pcie card: D-Link System Inc DGE-560T PCI Express Gigabit Ethernet Adapter (rev 13) [works fine] and on the MB Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 03) [it may have stopped working with the 3.10.* kernels]  Immediately after the install, both worked fine.  After the first kernel update, the realtek card stopped working altogether.  I have tried allowing NetworkManager to control the card and not doing so (both ways work under fc 17).

To check that the card is working, I put the old root (drive) file system from fedora 17 back in place, and when I booted, both cards came up and worked as expected - and did so for about 6 hours before I swapped the drives back and went back to fedora 19.

I'm not sure whether this is a NetworkManager problem, a kernel problem, a library problem or some other network-specific problem.  So the NetworkManager "component selection" above is a best-guess approximation.

manually setting the routing for the card does not help at all (or appear to work). The D-link card controls the external interfaces (ISP, other non-local systems) and the Realtek card is on the local (192.168.1.0) network.


Version-Release number of selected component (if applicable):
Not sure it's relevent but:
NetworkManager-0.9.8.2-8.git20130709.fc19.x86_64
kernel-3.10.7-200.fc19.x86_64 (same as with all other 3.10.* x86_64 kernels)


How reproducible:
Happens every time

Steps to Reproduce:
1.Reboot the machine (or restart network and NetworkManager)
2.
3.

Actual results:

D-Link (sky) card works as expected
Realtek card cannot contact anything on its network.

Expected results:

Both cards should work as expected

Additional info:\

Immediately after the initial install, both cards worked perfectly.  But after running yum update, the problem appeared.  Since there were > 400 updates in that first batch I don't have a clue which of them triggered the problem.
Comment 1 Rex Dieter 2013-09-18 10:58:42 EDT
*** Bug 999572 has been marked as a duplicate of this bug. ***
Comment 2 Rex Dieter 2013-09-18 10:58:48 EDT
*** Bug 999573 has been marked as a duplicate of this bug. ***
Comment 3 Jirka Klimes 2013-09-23 13:08:37 EDT
Could you please get the following data?
$ lspci -vvnn | grep Network
$ ip link
$ dmesg
$ NetworkManager log messages showing NM startup (/var/log/messages)
Comment 4 wwaustin 2014-04-29 17:06:19 EDT
As the problem went away when I went from FC19 to FC20 I'm going to say that it was apparently fixed at some point (either intentionally or otherwise).

As I can no longer reproduce the bug, I recommend that this bug be closed.
Comment 5 wwaustin 2014-04-29 17:07:08 EDT
As the problem went away when I went from FC19 to FC20 I'm going to say that it was apparently fixed at some point (either intentionally or otherwise).

As I can no longer reproduce the bug, I recommend that this bug be closed.
Comment 6 Jirka Klimes 2014-04-30 08:51:21 EDT
Closing per comment #4.

Note You need to log in before you can comment on or make changes to this bug.