Bug 999577 - ovirt-hosted-engine setup fails while setup of misc configuration: Failed to execute stage 'Misc configuration'.
ovirt-hosted-engine setup fails while setup of misc configuration: Failed to...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Leonid Natapov
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 11:23 EDT by Leonid Natapov
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.3.beta.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:52:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18406 None None None Never

  None (edit)
Description Leonid Natapov 2013-08-21 11:23:10 EDT
Description of problem:
ovirt-hosted-engine setup fails while setup of misc configuration:  Failed to execute stage 'Misc configuration'.


While setup ,when user was required to choose NIC,a list of NICs included also a bonds. I chose a bond as a required NIC. I think that it might be a problem. 

Here is the log:
----------------
2013-08-21 17:56:24 DEBUG otopi.plugins.ovirt_hosted_engine_setup.network.bridge plugin.execute:446 execute-output: ['/usr/bin/vdsClient', '-s', 'localhost', 'addNetwork', 'bridge=rhevm', 'vlan=', 'bond=', 'nics=bond2', 'force=False', 'b
ridged=True', 'BOOTPROTO=dhcp', 'ONBOOT=yes', 'blockingdhcp=true'] stderr:


2013-08-21 17:56:24 DEBUG otopi.context context._executeMethod:132 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 122, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/network/bridge.py", line 163, in _misc
    raiseOnError=True
  File "/usr/lib/python2.6/site-packages/otopi/plugin.py", line 451, in execute
    command=args[0],
RuntimeError: Command '/usr/bin/vdsClient' failed to execute
2013-08-21 17:56:24 ERROR otopi.context context._executeMethod:141 Failed to execute stage 'Misc configuration': Command '/usr/bin/vdsClient' failed to execute
-----------------

nics=bond2 but bond is empty.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Additional info:

ovirt-hosted-engine-setup-1.0.0-0.1.beta.el6.noarch
vdsm-4.12.0-68.gitc21f406.el6_4.x86_64
Comment 1 Sandro Bonazzola 2013-08-22 05:18:29 EDT
Previously all existing bond and bridge interfaces where
listed as possible nics for creating the management bridge.
If a bond interface was specified the bridge creation failed.

Now the bridge are not listed anymore and bonds are listed
only if they have slave interfaces.
If a bond interface with slaves is specified now should work
correctly.
Comment 2 Sandro Bonazzola 2013-08-23 02:20:07 EDT
patch merged upstream master.

Previously all existing bond and bridge interfaces where
listed as possible nics for creating the management bridge.
If a bond interface was specified the bridge creation failed.

Now the bridge are not listed anymore and bonds are listed
only if they have slave interfaces.
Enslaved interfaces and interfaces used by other bridges
are not listed anymore as available for management bridge
creation.

If a bond interface with slaves is specified now should work
correctly.
Comment 4 Leonid Natapov 2013-10-17 08:55:48 EDT
fixed.
Comment 5 Charlie 2013-11-27 20:19:06 EST
This bug is currently attached to errata RHBA-2013:15257. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 Sandro Bonazzola 2013-12-05 05:59:18 EST
hosted engine is a new package, does not need errata for specific bugs during its development.
Comment 7 errata-xmlrpc 2014-01-21 11:52:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0083.html

Note You need to log in before you can comment on or make changes to this bug.