Bug 999582 - SSL Support for newsreader Pan
SSL Support for newsreader Pan
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pan (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Alexander Dalloz
Fedora Extras Quality Assurance
: Reopened
: 1005134 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 11:43 EDT by Detlef Graef
Modified: 2015-12-11 20:53 EST (History)
10 users (show)

See Also:
Fixed In Version: pan-0.139-11.fc23 pan-0.139-11.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-09 13:41:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 693272 None None None Never

  None (edit)
Description Detlef Graef 2013-08-21 11:43:51 EDT
Description of problem:

Currently in Fedora 19 the newsreader Pan is build without SSL Support.

Is it possible to build Pan with SSL support by default in future releases of Fedora? 

Version-Release number of selected component (if applicable):

Pan 0.139

How reproducible:

Start Pan.

Steps to Reproduce:

Menue: Edit -> Edit Newsserver Profile -> Edit

Actual results:

There is no Button to activate SSL encrypted connections.

Expected results:

There is a Button to activate encrypted SSL connections.

Additional info:

During build process configure script should be run with the additional option:

--with-gnutls          # enable GnuTLS support (normally: no)
Comment 1 Petr Kovar 2014-01-03 12:38:07 EST
A licensing issue prevents us from linking Pan with libgnutls, so this will not fix:

https://bugzilla.gnome.org/show_bug.cgi?id=693272
Comment 2 Robert Scheck 2014-01-03 15:50:08 EST
This is interesting because the gnutls.spec file says right now:

> # The libraries are LGPLv2.1+, utilities are GPLv3+
> License: GPLv3+ and LGPLv2+

https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#GPLCompatibilityMatrix
says that linking GPLv2 software with a LGPLv2+ library is okay.

However I also found bug #1019408, but for RHEL 7. I guess this affects also
Fedora somehow? But if, why wasn't the spec file updated?
Comment 3 Robert Scheck 2014-01-03 15:56:12 EST
*** Bug 1005134 has been marked as a duplicate of this bug. ***
Comment 4 Michael Schwendt 2014-01-03 16:01:44 EST
It would also have been a very good idea to explain in the %changelog _why_ build option --without-gnutls has been enabled. The current entry "Disable support for GnuTLS" is not helpful.
Comment 5 Robert Scheck 2014-01-03 16:04:47 EST
Tom, if GnuTLS is effectively LGPLv3+ shouldn't the spec file reflect this?
Comment 6 Petr Kovar 2014-01-06 11:29:53 EST
(In reply to Robert Scheck from comment #2)
> This is interesting because the gnutls.spec file says right now:
> 
> > # The libraries are LGPLv2.1+, utilities are GPLv3+
> > License: GPLv3+ and LGPLv2+
> 
> https://fedoraproject.org/wiki/Licensing:
> Main?rd=Licensing#GPLCompatibilityMatrix
> says that linking GPLv2 software with a LGPLv2+ library is okay.
> 
> However I also found bug #1019408, but for RHEL 7. I guess this affects also
> Fedora somehow? But if, why wasn't the spec file updated?

Yes, due to the fact that GnuTLS is effectively LGPLv3+, we cannot really link it with Pan.

(In reply to Michael Schwendt from comment #4)
> It would also have been a very good idea to explain in the %changelog _why_
> build option --without-gnutls has been enabled. The current entry "Disable
> support for GnuTLS" is not helpful.

Good point. I added a comment explaining this change in the spec file (pan-0.139-6.fc21).
Comment 7 Nikos Mavrogiannopoulos 2014-04-29 10:24:09 EDT
This is no longer the case in rawhide. GnuTLS is LGPLv2+, and GMP (which was also LGPLv3+) is now available under GPLv2+ as well.
Comment 8 Petr Kovar 2014-04-29 10:52:30 EDT
(In reply to Nikos Mavrogiannopoulos from comment #7)
> This is no longer the case in rawhide. GnuTLS is LGPLv2+, and GMP (which was
> also LGPLv3+) is now available under GPLv2+ as well.

That's great news, thanks for the update.
Comment 9 Jaroslav Reznik 2015-03-03 11:54:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 10 Robin Laing 2015-03-16 00:24:30 EDT
I for one would like to start using ssl directly in PAN instead of stunnel.

I would like to see it in Fedora 21 unless it takes until 22 to recompile the program.
Comment 11 Detlef Graef 2015-12-02 05:29:18 EST
Changed to Fedora 23

Still no TLS support in pan on Fedora 23.

Installed version:

pan-0.139-10.fc23.x86_64
Comment 12 Fedora Update System 2015-12-02 11:41:14 EST
pan-0.139-11.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-beee3bb1a7
Comment 13 Fedora Update System 2015-12-03 11:01:10 EST
pan-0.139-11.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update pan'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-beee3bb1a7
Comment 14 Fedora Update System 2015-12-03 20:35:55 EST
pan-0.139-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update pan'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-0dffe0532f
Comment 15 Detlef Graef 2015-12-04 06:51:23 EST
I've tested the new version pan-0.139-11.fc23 on Fedora 23.

Pan has now working SSL/TLS support.

Ticket can be closed. If no problems are reported in the next days I will close this ticket.

Thanks a lot.
Comment 16 Robin Laing 2015-12-07 22:28:58 EST
I have tested the new version on FC22 and I am happy.  Some hickups but that is expected when changing news servers around.

Thank you for making this happen.  No need for stunnel (which has it's own problems) for secure usenet.
Comment 17 Fedora Update System 2015-12-11 18:51:06 EST
pan-0.139-11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2015-12-11 20:53:07 EST
pan-0.139-11.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.