Bug 999608 - Add redhat-access-plugin-rhos to horizon
Add redhat-access-plugin-rhos to horizon
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: z2
: 3.0
Assigned To: Matthias Runge
Keith Robertson
: ZStream
Depends On:
Blocks: 999082
  Show dependency treegraph
 
Reported: 2013-08-21 13:19 EDT by Matthias Runge
Modified: 2016-07-03 21:34 EDT (History)
13 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.1.3-2.el6ost
Doc Type: Enhancement
Doc Text:
An additional tab has been added to the Horizon dashboard GUI. This tab, titled "Red Hat", is on the left of the dashboard next to the "Project" and "Admin" tabs. It will only be visible if the redhat-access-plugin-rhos package has also been installed. (and httpd restarted) Selecting this tab enables access to Red Hat subscriber services from within the dashboard, such as: - Knowledge base article/solution viewing. - Diagnostic services on console logs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 15:59:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2013-08-21 13:19:23 EDT
add a hook to call the plugin
Comment 1 Matthias Runge 2013-08-21 14:02:27 EDT
This is how to test: install horizon, it should work ok. no support plugin (a third tab) should be shown.

Install the redhat-access-plugin-rhos package, restart httpd. The third tab should be shown, uninstall, restart httpd, plugin shall be gone.
Comment 3 Matthias Runge 2013-08-23 04:20:19 EDT
Thanks Julie! 

Before I can build this, I still need rhos-3.0.z == +
Comment 5 Bruce Reeler 2013-08-28 01:30:45 EDT
Needinfo for Julie Pichon
This bug requires Doc Text to be added for bug advisories. I have not been able to duplicate this on a VM, and am not sure what is meant by the "third tab". Is there a 3rd tab to be added on the left of Horizon's window, i.e. where there are currently a "Project" and "Admin" tabs? If so, what would the label be on the tab that the user sees?
Comment 6 Matthias Runge 2013-08-28 03:15:57 EDT
Bruce, that'll be something, kroberts or dvarga should be able to answer.
Comment 8 Dan Varga 2013-08-28 09:09:12 EDT
Bruce, https://mojo.redhat.com/docs/DOC-19348 contains some screen shots of what it would look like once the plugin is installed.  This bug only delivers the underlying plugin loading function.  Bug 999082 is the actual plugin and is a separate RPM.  You will NOT see the third tab until that RPM is installed.
Comment 9 Ami Jeain 2013-08-29 03:17:29 EDT
Hi Keith,
plz verify as agreed...

thanks
Comment 12 errata-xmlrpc 2013-09-03 15:59:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1186.html

Note You need to log in before you can comment on or make changes to this bug.