Bug 999667 - rhcsh should avoid calling load_env on erb files in env directories
rhcsh should avoid calling load_env on erb files in env directories
Status: CLOSED DUPLICATE of bug 999013
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 15:57 EDT by Andy Grimm
Modified: 2016-11-07 22:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 16:12:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Grimm 2013-08-21 15:57:14 EDT
Description of problem:

Several cartridges have erb templates in their env directory.  rhcsh tries to source them resulting in ugly errors:

bash: export: `OPENSHIFT_MYSQL_DB_LOG_DIR.erb=<%= ENV['OPENSHIFT_MYSQL_DIR'] %>/log/': not a valid identifier
bash: export: `OPENSHIFT_MYSQL_DB_SOCKET.erb=<%= ENV['OPENSHIFT_MYSQL_DIR'] %>/socket/mysql.sock': not a valid identifier
bash: export: `OPENSHIFT_PHP_LOG_DIR.erb=<%= ENV['OPENSHIFT_PHP_DIR'] %>/logs/': not a valid identifier
bash: export: `OPENSHIFT_PHP_LOG_DIR.erb=<%= ENV['OPENSHIFT_PHP_DIR'] %>/logs/': not a valid identifier
Comment 1 Dan McPherson 2013-08-21 16:12:39 EDT

*** This bug has been marked as a duplicate of bug 999013 ***

Note You need to log in before you can comment on or make changes to this bug.