Bug 999669 - [abrt] setroubleshoot-server-3.2.13-1.fc20: analyze.py:388:lookup_signature:ProgramError: [Errno 1001] signature not found
[abrt] setroubleshoot-server-3.2.13-1.fc20: analyze.py:388:lookup_signature:P...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
abrt_hash:b35fa9fb6e0c8460cde6786ab92...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 15:58 EDT by Peter Trenholme
Modified: 2013-08-22 08:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 08:09:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1021 bytes, text/plain)
2013-08-21 15:58 EDT, Peter Trenholme
no flags Details
File: environ (92 bytes, text/plain)
2013-08-21 15:58 EDT, Peter Trenholme
no flags Details

  None (edit)
Description Peter Trenholme 2013-08-21 15:58:47 EDT
Description of problem:
No idea - it popped whilst I was running an update (using smart, not yum, since smart is "smarter" about dependencies.)

Version-Release number of selected component:
setroubleshoot-server-3.2.13-1.fc20

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python -Es /usr/sbin/setroubleshootd -f ''
executable:     /usr/sbin/setroubleshootd
kernel:         3.11.0-0.rc6.git0.1.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
analyze.py:388:lookup_signature:ProgramError: [Errno 1001] signature not found

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/setroubleshoot/analyze.py", line 366, in auto_save_callback
    self.save()
  File "/usr/lib64/python2.7/site-packages/setroubleshoot/analyze.py", line 344, in save
    self.prune()
  File "/usr/lib64/python2.7/site-packages/setroubleshoot/analyze.py", line 309, in prune
    self.delete_signature(sig, prune=True)
  File "/usr/lib64/python2.7/site-packages/setroubleshoot/analyze.py", line 426, in delete_signature
    siginfo = self.lookup_signature(sig)
  File "/usr/lib64/python2.7/site-packages/setroubleshoot/analyze.py", line 388, in lookup_signature
    raise ProgramError(ERR_NO_SIGNATURE_MATCH)
ProgramError: [Errno 1001] signature not found

Local variables in innermost frame:
matches: []
siginfo: None
self: <setroubleshoot.analyze.SETroubleshootDatabase object at 0x7f0f0ab97650>
sig: <setroubleshoot.signature.SEFaultSignature object at 0x346c490>

Potential duplicate: bug 972510
Comment 1 Peter Trenholme 2013-08-21 15:58:50 EDT
Created attachment 788991 [details]
File: backtrace
Comment 2 Peter Trenholme 2013-08-21 15:58:52 EDT
Created attachment 788992 [details]
File: environ
Comment 3 Miroslav Grepl 2013-08-22 08:09:02 EDT
Could you try to execute

# killall -9 setroubleshootd
# > /var/lib/setroubleshoot/setroubleshoot_database.xml 


and see if this happens again. Thank you.

Note You need to log in before you can comment on or make changes to this bug.