Bug 999719 - [RFE] UI: batch actions for efficiency
[RFE] UI: batch actions for efficiency
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
unspecified
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: nobody nobody
Pavel Stehlik
: FutureFeature, Reopened, UserExperience
: 720746 1191154 (view as bug list)
Depends On:
Blocks: 1235630
  Show dependency treegraph
 
Reported: 2013-08-21 18:29 EDT by Kevin Clevenger
Modified: 2016-11-10 02:49 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-10 02:49:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sherold: Triaged+


Attachments (Terms of Use)

  None (edit)
Comment 1 Itamar Heim 2013-08-21 21:34:23 EDT
Kevin - please provide more details on the request. thanks
Comment 6 Einav Cohen 2014-03-07 11:12:58 EST
*** Bug 720746 has been marked as a duplicate of this bug. ***
Comment 7 Einav Cohen 2015-02-11 08:32:39 EST
a more detailed description for this BZ:

today, bulk operations are typically available only for actions that don't require a user input via a dialog; e.g. no problem to run multiple VMs at once, or remove multiple VMs at once (after confirming the 'Are You Sure' dialog), but you cannot e.g. edit multiple VMs at once, assign tags to multiple VMs at once, etc. 

we already have a general idea on how to solve it for 4.0. 

another type of bulk operation that is missing at the moment (mentioned in bug 720746, bug 1074026 and bug 1191154) is operations from sub-tabs: such operation  apply only to one item by definition - the item that is selected in the main tab). 

e.g. when selecting multiple VMs, the displayed Permissions sub-tab (along with all other sub-tabs next to it) pertains only to one of the selected VMs in the main grid, not to all of them. 
Consequently, performing an Add Permission action via this sub-tab will pertain only to the VM to which the Permissions sub-tab pertains. 

We have some evidence from users with regards to being able to e.g. assign permissions on multiple objects at once - so need to think about how to allow that [make it available on the main-grid action-panel? make sure that the sub-tabs pertain somehow to all selected objects in the main grid, rather than to only one of them (sounds tricky)?].
Comment 8 Einav Cohen 2015-02-11 08:36:21 EST
*** Bug 1191154 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.