Bug 999724 - SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from 'create' accesses on the file reg7050000.tmp.
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from 'creat...
Status: CLOSED DUPLICATE of bug 999691
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:717284e01bb4ed3dfdd2b4ac22f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 19:06 EDT by Moez Roy
Modified: 2013-08-22 05:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 05:04:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-08-21 19:06:35 EDT
Description of problem:
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wineserver from 'create' accesses on the file reg7050000.tmp.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that wineserver should be allowed create access on the reg7050000.tmp file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wineserver /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:config_home_t:s0
Target Objects                reg7050000.tmp [ file ]
Source                        wineserver
Source Path                   /opt/teamviewer8/tv_bin/wine/bin/wineserver
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           teamviewer-8.0.17147-1.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-100.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.4-100.fc18.x86_64 #1 SMP Thu
                              Aug 1 21:13:27 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-08-20 08:54:24 PDT
Last Seen                     2013-08-20 08:54:24 PDT
Local ID                      b6462bc1-d177-44dd-9f6f-bc5c769502dd

Raw Audit Messages
type=AVC msg=audit(1377014064.57:1396): avc:  denied  { create } for  pid=1797 comm="wineserver" name="reg7050000.tmp" scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:config_home_t:s0 tclass=file


type=SYSCALL msg=audit(1377014064.57:1396): arch=i386 syscall=fstat success=yes exit=EBADFD a0=9b25028 a1=80c1 a2=1b6 a3=0 items=0 ppid=1 pid=1797 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=wineserver exe=/opt/teamviewer8/tv_bin/wine/bin/wineserver subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: wineserver,initrc_t,config_home_t,file,create

audit2allow

#============= initrc_t ==============
allow initrc_t config_home_t:file create;

audit2allow -R
require {
	type initrc_t;
}

#============= initrc_t ==============
gnome_manage_home_config(initrc_t)


Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.4-100.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-22 05:04:30 EDT

*** This bug has been marked as a duplicate of bug 999691 ***

Note You need to log in before you can comment on or make changes to this bug.