Bug 999725 - RFE: Keyboard shortcut to remove copied source text
RFE: Keyboard shortcut to remove copied source text
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Isaac Rooskov
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-21 19:18 EDT by Isaac Rooskov
Modified: 2015-08-06 01:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 01:19:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Isaac Rooskov 2013-08-21 19:18:53 EDT
Description of problem:

RFE from Aiko (asasaki@redhat.com):

"When translating, we firstly press Alt + G to copy source text.
After finishing translating source to target, you always have to delete the copied source manually and this speed is very slow. If there were a function or command available to delete the remaining source text to the end of the sentence (or the end of the segment) at one time, that will save lots of time."
Comment 1 Sean Flanigan 2013-08-21 20:26:54 EDT
How about Ctrl-Shift-End followed by the Delete key?  This should work in almost anything - browsers, text editors, etc.

Actually, I usually use Shift-PgDn, Delete, since it's a bit easier to press.  If there's more than one page, you can just hold down PgDn for a bit longer.


Ctrl-Shift-End will select from cursor to end of buffer, then Delete deletes the selection.

Likewise Shift-PgDn will select from cursor to end of page, and it adds another page if you press PgDn again.


I'm using GNOME 2, but most environments should offer similar editing shortcuts, and many others.
Comment 2 Ding-Yi Chen 2013-08-22 03:42:15 EDT
Hi Aiko,

Does Sean's suggesting work for you?
Comment 3 Aiko 2013-09-13 00:50:19 EDT
Yes, Sean's suggestion works well.
Thanks
Comment 4 Ding-Yi Chen 2013-09-13 01:19:01 EDT
As the functionality is provided by browser, not Zanata itself. I hereby close this bug as NOTABUG. Feel free to reopen this bug if you have further concern.

Note You need to log in before you can comment on or make changes to this bug.