Bug 999799 - Network QoS burst units should be MB
Network QoS burst units should be MB
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Doron Fediuck
GenadiC
sla
:
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-08-22 03:28 EDT by ofri
Modified: 2016-02-10 15:15 EST (History)
9 users (show)

See Also:
Fixed In Version: is12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:13:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18395 None None None Never
oVirt gerrit 18398 None None None Never

  None (edit)
Description ofri 2013-08-22 03:28:05 EDT
Description of problem:
The units of the network QoS 'Burst' property should always be in Mega-Bytes, not Mega-bits.

Version-Release number of selected component (if applicable):


How reproducible:
100%


Additional info:
need to be fixed in UI
Comment 1 ofri 2013-08-22 03:44:17 EDT
Adding to this bug:

- the translation of QoS units from the engine to vdsm is wrong. 
current translation is Mb --> Kb
should be              Mb --> KB (since vdsm works in kilobytes)
Comment 2 GenadiC 2013-08-29 05:47:49 EDT
The value is MiB when it should be MB
Comment 3 ofri 2013-09-02 01:54:32 EDT
according to Wikipedia: 
Mebibyte (MiB) - 2^20 Byte (1024 Kibibyte)
Megabyte (MB) - three different values depending on context: 
   2^20 bytes generally for computer memory
   one million bytes generally for computer storage or transmission rates
   and in rare cases 1000×1024 (1024000) bytes

I think Mib is less ambiguous and there for better.
Comment 6 Itamar Heim 2014-01-21 17:13:50 EST
Closing - RHEV 3.3 Released
Comment 7 Itamar Heim 2014-01-21 17:21:37 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.