Bug 999800 - Errors encountered while deploying OO using puppet. [NEEDINFO]
Errors encountered while deploying OO using puppet.
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Documentation (Show other bugs)
2.x
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: mfisher
ecs-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 03:29 EDT by Kannan
Modified: 2017-05-31 14:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kraman: needinfo? (kannagov)


Attachments (Terms of Use)

  None (edit)
Description Kannan 2013-08-22 03:29:28 EDT
Description of problem:

Reference: http://openshift.github.io/documentation/oo_deployment_guide_puppet.html 

We are trying to install Openshift Origin on RHEL 6.4 following the link mentioned above, and we are facing many issues. 

1. The document advices to install the EPEL repo in the host before starting the installation. If we do so, the package mcollective-common 2.2.3 gets installed from the epel-testing.repo. Whereas the puppet looks for version 2.2.1 and fails. 

2. The repo file openshift-origin-deps.repo gets installed/updated with the baseurl=https://mirror.openshift.com/pub/openshift-origin/rhel-6/x86_64/ . This url is broken. The new url seems to be https://mirror.openshift.com/pub/openshift-origin/nightly/rhel-6/dependencies/x86_64/ .
Comment 1 Bilhar 2013-08-22 05:27:57 EDT
As we don't maintain the Origin docs at this time, I'm reassigning this BZ to Krishna to investigate.
Comment 2 Krishna Raman 2013-08-22 11:53:40 EDT
Due to some reorganization on the public mirror, some of the files were moved around. The puppet script has been updated (on Aug 21st 4pm PST) to match the new directory structure.

Please update your puppet module and try again.
Comment 3 Kannan 2013-08-22 13:48:39 EDT
Thanks Raman. We will update the puppet modules and try again and update the bug with the results.
Comment 4 Krishna Raman 2013-12-09 18:10:29 EST
Can I close this issue?
Comment 6 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.