Bug 999829 - openstack-packstack: ntp servers aren't configured after the server's reboot
openstack-packstack: ntp servers aren't configured after the server's reboot
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
x86_64 Linux
medium Severity high
: beta
: 4.0
Assigned To: Martin Magr
Nir Magnezi
:
Depends On:
Blocks: 1034358
  Show dependency treegraph
 
Reported: 2013-08-22 04:40 EDT by Yogev Rabl
Modified: 2016-04-26 13:45 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1034358 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:19:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The openstack-packstack answer file (10.64 KB, text/plain)
2013-08-22 05:02 EDT, Yogev Rabl
no flags Details
the ntp conf file (1.91 KB, text/plain)
2013-08-22 05:03 EDT, Yogev Rabl
no flags Details
The log files archived. (13.07 KB, application/x-gzip)
2013-08-22 07:21 EDT, Yogev Rabl
no flags Details

  None (edit)
Comment 2 Yogev Rabl 2013-08-22 05:01:00 EDT
Description of problem:
The NTP servers configured during the openstack-packstack installation should appear in the /etc/ntp.conf file. 
The verification of the packstack installation shows that the servers aren't configure.  

Version-Release number of selected component (if applicable):
2013.1.3-2.el6ost

How reproducible:


Steps to Reproduce:
1. Run openstack-packstack with the answer file attached on RHEL 6.4 server.
2. Reboot the server.
3. Check the /etc/ntp.conf file for the servers: 10.16.255.2, 10.16.255.3

Actual results:
the server server clock.redhat.com is the only server configured in the /etc/ntp.conf file.

Expected results:
In the /etc/ntp.conf file:
server clock.redhat.com
server 10.16.255.2
server 10.16.255.3
Comment 3 Yogev Rabl 2013-08-22 05:02:12 EDT
Created attachment 789101 [details]
The openstack-packstack answer file
Comment 4 Yogev Rabl 2013-08-22 05:03:14 EDT
Created attachment 789102 [details]
the ntp conf file
Comment 5 Yogev Rabl 2013-08-22 07:21:09 EDT
Created attachment 789152 [details]
The log files archived.
Comment 6 Alvaro Lopez Ortega 2013-11-15 06:59:57 EST
It should be fixed in the current release.
Comment 8 Scott Lewis 2013-11-19 11:54:32 EST
Auto adding >= MODIFIED bugs to beta
Comment 14 Nir Magnezi 2013-12-18 03:53:07 EST
Verified NVR: openstack-packstack-2013.2.1-0.20.dev936.el6ost.noarch

1. Installed openstack via packstack , used a local NTP server (See comment #2).
2. Rebooted the server.

Result:
=======
NTP configuration remains the same post reboot.
Comment 16 errata-xmlrpc 2013-12-19 19:19:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.