Bug 999840 - ovirt-hosted-engine setup fails to mount storage domain because vdsm uses wrong path.
ovirt-hosted-engine setup fails to mount storage domain because vdsm uses wro...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3.0
Assigned To: Eduardo Warszawski
Leonid Natapov
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 05:02 EDT by Leonid Natapov
Modified: 2016-02-10 14:55 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously ovirt-hosted-engine setup failed to mount a storage domain because VDSM used the wrong mount path. The mount path is now correct, so the setup executes as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:13:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 4220 None None None Never

  None (edit)
Description Leonid Natapov 2013-08-22 05:02:57 EDT
ovirt-hosted-engine setup fails to mount storage domain because vdsm uses wrong mount path.

Thread-41::ERROR::2013-08-21 19:38:56,895::dispatcher::67::Storage.Dispatcher.Protect::(run) {'status': {'message': "Image path does not exist or cannot be accessed/created: ('/rhev/data-center/00000000-0000-000
<sbonazzo> 0-0000-000000000000/f77caf6d-c42c-4dbe-b17a-3d77c0ae9584/images/08cfdad8-fd72-471e-9f32-121208bae36e',)", 'code': 254}}

it's using /rhev/data-center/ instead of /rhev/data-center/mnt/orion.qa.lab.tlv.redhat.com\:_export_hosted__engine/


setup fails.

Rreproduce:
100%

Additional info:

ovirt-hosted-engine-setup-1.0.0-0.1.beta.el6.noarch
vdsm-4.12.0-68.gitc21f406.el6_4.x86_64
Comment 2 Eduardo Warszawski 2013-08-27 01:50:27 EDT
Please add the complete log.
The provided trace is insufficient.
Comment 6 Eduardo Warszawski 2013-10-02 08:27:16 EDT
Still lacks the logs required in comment#2.

In principle, since Change-Id: Id47db9c53199385dd5d08586e4782ea23885eb72 is merged , should be ON_QA.

This bug probably was opened without the necessary code.
Comment 7 Leonid Natapov 2013-11-03 06:58:40 EST
fixed.
Comment 8 Charlie 2013-11-27 19:33:41 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 11:13:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.