Bug 999853 - Resarting supervdsmd service after performing libvirt reconfigure
Resarting supervdsmd service after performing libvirt reconfigure
Status: CLOSED ERRATA
Product: ovirt-host-deploy
Classification: oVirt
Component: Plugins.VDSM (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: 1.1.1
Assigned To: Yaniv Bronhaim
Tareq Alayan
infra
: AutomationBlocker
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-08-22 05:30 EDT by Yaniv Bronhaim
Modified: 2016-02-10 14:41 EST (History)
10 users (show)

See Also:
Fixed In Version: is15
Doc Type: Bug Fix
Doc Text:
Previously, libvirt-reconfigure automatically restarted the libvirtd and supervdsm services after the reconfiguration. Now, instead of restarting both services, users receive a message requesting them to manually perform the restart by using the libvirt-configure-services-restart command. For backward compatibility with systemd, this also updates the systemd-vdsmd script to restart the libvirtd and supervdsmd in previous versions.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:13:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bazulay: devel_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18780 None None None Never

  None (edit)
Description Yaniv Bronhaim 2013-08-22 05:30:15 EDT
Description of problem:
libvirt-reconfigure performs libvirtd service restart, if supervdsmd was started before running the reconfigure, we should restart supervdsmd after libvirtd restart to re-established the connection between the two. 

ovirt-host-deploy takes care of restarting vdsmd after reconfigure. Before vdsm 3.3 that contains the separation of supervdsmd to external service, restart vdsmd was enough - as it was restarting also supervdsm process. Now, when supervdsmd is external to vsdmd we should take care of it separately, and for backwards compatibility it's not enough to add it only for new version of ovirt-host-deploy. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. run vdsm-tool reconfigure-libvirt force
2. call vdsClient setupNetworks ..


Actual results:
supervdsmd fails to execute the setupNetworks verb that contain calls to libvirt, get an sigterm and restarts. first call fails, second works.


Expected results:
supervdsmd should response normally after reconfigure libvirt and perform the action.
Comment 1 Tareq Alayan 2013-10-17 06:55:37 EDT
verified on vdsm-4.13.0-0.2.beta1.el6ev.x86_64
Comment 2 Charlie 2013-11-27 19:26:17 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 3 errata-xmlrpc 2014-01-21 11:13:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.