Bug 999943 - SELinux is preventing /usr/bin/convert from 'create' accesses on the file magick9UzNS0.
SELinux is preventing /usr/bin/convert from 'create' accesses on the file mag...
Status: CLOSED DUPLICATE of bug 830411
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:11d0bc0b999bc0945db632793fa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 08:10 EDT by Renich Bon Ciric
Modified: 2014-03-03 06:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 08:52:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Renich Bon Ciric 2013-08-22 08:10:26 EDT
Description of problem:
I was copying files through samba
SELinux is preventing /usr/bin/convert from 'create' accesses on the file magick9UzNS0.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that convert should be allowed create access on the magick9UzNS0 file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep convert /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                magick9UzNS0 [ file ]
Source                        convert
Source Path                   /usr/bin/convert
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ImageMagick-6.7.8.9-5.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-71.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.7-200.fc19.x86_64 #1 SMP Thu
                              Aug 15 23:19:45 UTC 2013 x86_64 x86_64
Alert Count                   52
First Seen                    2013-08-22 05:12:59 CDT
Last Seen                     2013-08-22 07:09:09 CDT
Local ID                      5dd4183e-f381-4998-adbc-590617c65319

Raw Audit Messages
type=AVC msg=audit(1377173349.516:529): avc:  denied  { create } for  pid=15482 comm="convert" name="magick9UzNS0" scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file


type=SYSCALL msg=audit(1377173349.516:529): arch=x86_64 syscall=open success=no exit=EACCES a0=e3dc90 a1=c2 a2=180 a3=0 items=0 ppid=15467 pid=15482 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=convert exe=/usr/bin/convert subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)

Hash: convert,thumb_t,user_home_dir_t,file,create

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.7-200.fc19.x86_64
type:           libreport

Potential duplicate: bug 830411
Comment 1 Miroslav Grepl 2013-08-27 08:52:01 EDT

*** This bug has been marked as a duplicate of bug 830411 ***

Note You need to log in before you can comment on or make changes to this bug.