Bug 1998261 (CVE-2006-1236) - CVE-2006-1236 crossfire: allows remote attackers to execute arbitrary code via a long setup sound command
Summary: CVE-2006-1236 crossfire: allows remote attackers to execute arbitrary code vi...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2006-1236
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1998262
TreeView+ depends on / blocked
 
Reported: 2021-08-26 17:28 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-08-31 18:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-31 18:56:37 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2021-08-26 17:28:50 UTC
Buffer overflow in the SetUp function in socket/request.c in CrossFire 1.9.0 allows remote attackers to execute arbitrary code via a long setup sound command, a different vulnerability than CVE-2006-1010.

Reference:
https://exchange.xforce.ibmcloud.com/vulnerabilities/25252

Comment 1 Gwyn Ciesla 2021-08-26 18:45:36 UTC
I can't find a reference to the code that needs fixing, or a patch. We now ship 1.75.1, I wonder if this still applies.

Comment 2 Stefan Cornelius 2021-08-31 12:22:48 UTC
CVE-2006-1010 was for "Crossfire, a multiplayer adventure game". That's not the crossfire we ship in CodeReady Studio.

Comment 3 Product Security DevOps Team 2021-08-31 18:56:37 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2006-1236


Note You need to log in before you can comment on or make changes to this bug.