MediaWiki has just made a release with a security vulnerabiliy fixed:
This means that FC6 and devel branches should be upgraded to 1.8.3.
The situation for FC5 is more complex, as it is shipping 1.5.8 which is
considered obsolete by upstream it seems. It may need to be upgraded to the
1.6.x or later series.
Building updated packages.
Packages are waiting in the needsign queue.
For reference, this is CVE-2007-0177