Bug 392901 (CVE-2007-4767) - CVE-2007-4767: pcre < 7.3 \p, \P, \P{x] length calculation issue
Summary: CVE-2007-4767: pcre < 7.3 \p, \P, \P{x] length calculation issue
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: CVE-2007-4767
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 378411
Blocks: 307451
TreeView+ depends on / blocked
 
Reported: 2007-11-20 19:50 UTC by Ville Skyttä
Modified: 2019-09-29 12:22 UTC (History)
1 user (show)

Fixed In Version: 7.3-3.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-06 16:36:50 UTC


Attachments (Terms of Use)

Description Ville Skyttä 2007-11-20 19:50:19 UTC
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2007-4767

"Perl-Compatible Regular Expression (PCRE) library before 7.3 does not properly
compute the length of (1) a \p sequence, (2) a \P sequence, or (3) a \P{x}
sequence, which allows context-dependent attackers to cause a denial of service
(infinite loop or crash) or execute arbitrary code."

F7 ships pcre 7.0.

Comment 1 Fedora Update System 2008-02-15 16:34:36 UTC
pcre-7.3-3.fc7 has been submitted as an update for Fedora 7

Comment 2 Fedora Update System 2008-02-19 03:20:16 UTC
pcre-7.3-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pcre'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-1842

Comment 3 Fedora Update System 2008-03-06 16:36:26 UTC
pcre-7.3-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.