Bug 879292 (CVE-2008-0456) - CVE-2008-0456 httpd: mod_negotiation CRLF injection via untrusted file names in directories with MultiViews enabled
Summary: CVE-2008-0456 httpd: mod_negotiation CRLF injection via untrusted file names ...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2008-0456
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 816611
TreeView+ depends on / blocked
 
Reported: 2012-11-22 14:48 UTC by Tomas Hoger
Modified: 2021-02-17 08:21 UTC (History)
1 user (show)

Fixed In Version: httpd 2.2.12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-08 07:59:38 UTC
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2013:0130 0 normal SHIPPED_LIVE Low: httpd security, bug fix, and enhancement update 2013-01-08 09:33:40 UTC

Description Tomas Hoger 2012-11-22 14:48:13 UTC
CVE-2008-0456 was assigned to the following issue:

CRLF injection vulnerability in the mod_negotiation module in the Apache HTTP Server 2.2.6 and earlier in the 2.2.x series, 2.0.61 and earlier in the 2.0.x series, and 1.3.39 and earlier in the 1.3.x series allows remote authenticated users to inject arbitrary HTTP headers and conduct HTTP response splitting attacks by uploading a file with a multi-line name containing HTTP header sequences and a file extension, which leads to injection within a (1) "406 Not Acceptable" or (2) "300 Multiple Choices" HTTP response when the extension is omitted in a request for the file. 

References:
http://www.mindedsecurity.com/MSA01150108.html
http://www.securityfocus.com/archive/1/archive/1/486847/100/0/threaded

The issue was corrected upstream in httpd 2.2.12:
https://issues.apache.org/bugzilla/show_bug.cgi?id=46837
http://svn.apache.org/viewvc?view=revision&revision=752812
http://httpd.apache.org/security/vulnerabilities_22.html#2.2.12

Note that the XSS issue reported as the same time only got corrected in httpd 2.2.23 as CVE-2012-2687 (see bug 850794, comment 17).

Comment 1 Tomas Hoger 2012-11-22 14:50:05 UTC
(In reply to comment #0)
> The issue was corrected upstream in httpd 2.2.12:

Red Hat Enterprise Linux 6 include httpd version 2.2.15 and hence was never affected by this issue.

Comment 2 errata-xmlrpc 2013-01-08 05:04:44 UTC
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5

Via RHSA-2013:0130 https://rhn.redhat.com/errata/RHSA-2013-0130.html

Comment 4 Tomas Hoger 2013-01-08 07:59:38 UTC
Statement:

(none)


Note You need to log in before you can comment on or make changes to this bug.