Bug 476823 (CVE-2008-5587) - CVE-2008-5587 phpPgAdmin: directory traversal flaw in libraries/lib.inc.php
Summary: CVE-2008-5587 phpPgAdmin: directory traversal flaw in libraries/lib.inc.php
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2008-5587
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL: http://nvd.nist.gov/nvd.cfm?cvename=C...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-12-17 11:23 UTC by Tomas Hoger
Modified: 2019-09-29 12:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-09 08:40:57 UTC


Attachments (Terms of Use)

Description Tomas Hoger 2008-12-17 11:23:55 UTC
Common Vulnerabilities and Exposures assigned an identifier CVE-2008-5587 to the following vulnerability:

Directory traversal vulnerability in libraries/lib.inc.php in
phpPgAdmin 4.2.1 and earlier, when register_globals is enabled, allows
remote attackers to read arbitrary files via a .. (dot dot) in the
_language parameter to index.php.

References:
http://www.milw0rm.com/exploits/7363
http://www.securityfocus.com/bid/32670
http://secunia.com/advisories/33014

Upstream bug:
http://sourceforge.net/tracker/?func=detail&group_id=37132&atid=418980&aid=2422429
(no fix there yet, making sure $_language is unset before use should do the
trick)

Comment 1 Fedora Update System 2008-12-19 07:44:58 UTC
phpPgAdmin-4.2.2-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/phpPgAdmin-4.2.2-1.fc9

Comment 2 Fedora Update System 2008-12-19 07:45:14 UTC
phpPgAdmin-4.2.2-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/phpPgAdmin-4.2.2-1.fc10

Comment 3 Fedora Update System 2008-12-19 07:45:50 UTC
phpPgAdmin-4.2.2-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/phpPgAdmin-4.2.2-1.fc8

Comment 4 Tomas Hoger 2008-12-19 08:13:13 UTC
Fixed upstream in 4.2.2.

Upstream patch:
http://github.com/xzilla/phppgadmin/commit/b62ff9fa11f0dbed1a28568671eb31d45a5363dd

Comment 5 Devrim GUNDUZ 2008-12-19 08:30:28 UTC
Tomas,

Already pushed the package(s) to repositories :) . I contacted with phpPgAdmin team yesterday, and they provided a quick fix.

Comment 6 Fedora Update System 2008-12-21 08:32:37 UTC
phpPgAdmin-4.2.2-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2008-12-21 08:38:54 UTC
phpPgAdmin-4.2.2-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2008-12-21 08:41:56 UTC
phpPgAdmin-4.2.2-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Red Hat Product Security 2009-01-09 08:40:57 UTC
This issue was addressed in:

Fedora:
  https://admin.fedoraproject.org/updates/F10/FEDORA-2008-11564
  https://admin.fedoraproject.org/updates/F9/FEDORA-2008-11602


Note You need to log in before you can comment on or make changes to this bug.