Bug 568184 (CVE-2010-0051, CVE-2010-0651) - CVE-2010-0651 webkit: remote information disclosure
Summary: CVE-2010-0651 webkit: remote information disclosure
Keywords:
Status: NEW
Alias: CVE-2010-0051, CVE-2010-0651
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL: http://web.nvd.nist.gov/view/vuln/det...
Whiteboard: impact=low,source=cve,reported=200202...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-24 23:12 UTC by Vincent Danen
Modified: 2019-06-08 12:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Vincent Danen 2010-02-24 23:12:21 UTC
Common Vulnerabilities and Exposures assigned an identifier CVE-2010-0651 to
the following vulnerability:

WebKit before r52784, as used in Google Chrome before 4.0.249.78 and Apple Safari, permits cross-origin loading of CSS stylesheets even when the stylesheet download has an incorrect MIME type and the stylesheet document is malformed, which allows remote HTTP servers to obtain sensitive information via a crafted document.

http://code.google.com/p/chromium/issues/detail?id=9877
http://googlechromereleases.blogspot.com/2010/01/stable-channel-update_25.html
http://sites.google.com/a/chromium.org/dev/Home/chromium-security/chromium-security-bugs
http://trac.webkit.org/changeset/52784
https://bugs.webkit.org/show_bug.cgi?id=29820
http://securitytracker.com/id?1023506

Comment 1 Vincent Danen 2010-02-25 05:04:19 UTC
See bug #568231 for the bug filed for Firefox (CVE-2010-0654).

The original report for this:

http://scarybeastsecurity.blogspot.com/2009/12/generic-cross-browser-cross-domain.html

and an upstream WebKit bug report (currently not public):

https://bugs.webkit.org/show_bug.cgi?id=29820

Comment 11 Vincent Danen 2010-04-09 22:11:36 UTC
This has been addressed in Qt via: qt-4.6.2-8.fc12, qt-4.6.2-8.fc11, and qt-4.6.2-8.fc13 (see bug #570349).

Comment 12 Vincent Danen 2010-04-23 16:49:30 UTC
Not sure when this was addressed in webkitgtk, but looking at the files in 1.2.0, this is corrected there.  This means that Fedora 11 and 12 may still be problematic, but rawhide has 1.2.0 in it.

Comment 14 Tomas Hoger 2010-04-29 19:27:39 UTC
Adding CVE-2010-0051 as another bug alias based on:
  https://bugzilla.redhat.com/show_bug.cgi?id=570349#c3


Note You need to log in before you can comment on or make changes to this bug.