Bug 651204 (CVE-2010-3436) - CVE-2010-3436 php: open_basedir bypass via fopen_wrappers.c
Summary: CVE-2010-3436 php: open_basedir bypass via fopen_wrappers.c
Keywords:
Status: CLOSED DUPLICATE of bug 169857
Alias: CVE-2010-3436
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-09 00:15 UTC by Vincent Danen
Modified: 2021-02-24 17:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-09 00:18:13 UTC


Attachments (Terms of Use)

Description Vincent Danen 2010-11-09 00:15:41 UTC
Common Vulnerabilities and Exposures assigned an identifier CVE-2010-3436 to
the following vulnerability:

Name: CVE-2010-3436
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-3436
Assigned: 20100917
Reference: CONFIRM: http://security-tracker.debian.org/tracker/CVE-2010-3436
Reference: CONFIRM: http://svn.php.net/viewvc/php/php-src/trunk/main/fopen_wrappers.c?r1=303824&r2=303823&pathrev=303824
Reference: CONFIRM: http://svn.php.net/viewvc?view=revision&revision=303824
Reference: MANDRIVA:MDVSA-2010:218
Reference: URL: http://www.mandriva.com/security/advisories?name=MDVSA-2010:218

fopen_wrappers.c in PHP 5.3.x through 5.3.3 might allow remote
attackers to bypass open_basedir restrictions via vectors related to
the length of a filename.

Comment 1 Vincent Danen 2010-11-09 00:18:13 UTC
Closing as dupe of bug 169857.

*** This bug has been marked as a duplicate of bug 169857 ***

Comment 2 Tomas Hoger 2012-05-15 16:29:29 UTC
Statement:

We do not consider safe_mode / open_basedir restriction bypass issues to be security sensitive.  For more details see http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169857#c1 and http://www.php.net/security-note.php


Note You need to log in before you can comment on or make changes to this bug.