Bug 746880 (CVE-2011-3646, CVE-2011-4064) - CVE-2011-3646 CVE-2011-4064 phpMyAdmin: multiple flaws corrected in 3.4.6 (PMASA-2011-15, PMASA-2011-16)
Summary: CVE-2011-3646 CVE-2011-4064 phpMyAdmin: multiple flaws corrected in 3.4.6 (PM...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2011-3646, CVE-2011-4064
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 746882 746883 746884
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-18 05:01 UTC by Vincent Danen
Modified: 2019-09-29 12:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-19 15:37:44 UTC


Attachments (Terms of Use)

Description Vincent Danen 2011-10-18 05:01:23 UTC
Multiple flaws were reported in versions of phpMyAdmin prior to 3.4.6.  The first is a path disclosure due to insufficient URL parameter validation [1] (PMASA-2011015, CVE-2011-3646).  The second is an XSS flaw in setup.php where crafted values entered in the setup interface can produce an XSS; if the configuration directory exists and is writable (non-default, not recommended), the XSS payload can be saved to the directory [2] (PMASA-2011-16, CVE-2011-4064).

Current Fedora and EPEL5 and 6 contain phpMyAdmin 3.4.5 which is vulnerable to these flaws.

[1] http://www.phpmyadmin.net/home_page/security/PMASA-2011-15.php
[2] http://www.phpmyadmin.net/home_page/security/PMASA-2011-16.php

Comment 1 Vincent Danen 2011-10-18 05:02:59 UTC
Created phpMyAdmin tracking bugs for this issue

Affects: fedora-all [bug 746882]
Affects: epel-6 [bug 746884]

Comment 2 Vincent Danen 2011-10-18 05:03:01 UTC
Created phpMyAdmin3 tracking bugs for this issue

Affects: epel-5 [bug 746883]

Comment 3 Fedora Update System 2011-11-13 01:33:46 UTC
phpMyAdmin3-3.4.7-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2011-11-13 01:34:31 UTC
phpMyAdmin-3.4.7-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2011-11-13 05:33:34 UTC
phpMyAdmin-3.4.7-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2011-11-13 05:34:05 UTC
phpMyAdmin-3.4.7-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-11-13 05:34:58 UTC
phpMyAdmin-3.4.7-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.