Bug 803028 (CVE-2012-1163) - CVE-2012-1163 libzip: integer overflow when processing malformed zip file
Summary: CVE-2012-1163 libzip: integer overflow when processing malformed zip file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: CVE-2012-1163
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 805102 805104
Blocks: 802568
TreeView+ depends on / blocked
 
Reported: 2012-03-13 19:40 UTC by Vincent Danen
Modified: 2021-02-24 12:55 UTC (History)
5 users (show)

Fixed In Version: libzip 0.10.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-16 14:53:53 UTC


Attachments (Terms of Use)
patch from upstream (806 bytes, patch)
2012-03-15 21:11 UTC, Vincent Danen
no flags Details | Diff

Description Vincent Danen 2012-03-13 19:40:11 UTC
An integer overflow vulnerability was reported in libzip <= 0.10 when processing certain corrupt zip files.  When libzip opens a zip file, it reads in the size and the offset of the central directory structure and, while it performs a consistency check on these values, it does not anticipate an integer overflow.  In this case libzip will continue to process the zip file, which may result in the improper restrictions of operations within the bounds of a memory buffer.


Acknowledgements:

Red Hat would like to thank Timo Warns for reporting this issue.

Comment 1 Vincent Danen 2012-03-15 21:11:54 UTC
Created attachment 570438 [details]
patch from upstream

Comment 3 Vincent Danen 2012-03-20 14:54:14 UTC
Created php tracking bugs for this issue

Affects: fedora-all [bug 805104]

Comment 4 Vincent Danen 2012-03-20 14:54:19 UTC
Created libzip tracking bugs for this issue

Affects: fedora-all [bug 805102]

Comment 6 Stefan Cornelius 2012-03-28 04:26:02 UTC
The vulnerability was introduced by patch http://hg.nih.at/libzip?cs=feb6cbf7e8c4 in version 0.10.

Statement:

Not vulnerable. This issue did not affect the versions of libzip and php as shipped with Red Hat Enterprise Linux 6. This issue did not affect the versions of php53 as shipped with Red Hat Enterprise Linux 5.

Comment 7 Fedora Update System 2012-04-12 02:48:23 UTC
libzip-0.10.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Stefan Cornelius 2012-04-16 14:53:53 UTC
Vulnerability was introduced in a version later than shipped with F15 and F16. F17 now ships version 0.10.1, which fixes the issue.


Note You need to log in before you can comment on or make changes to this bug.